Question i9 10900K Boosting 6.5GHz (By Itself)

eL3ctro

Distinguished
Apr 17, 2015
87
0
18,640
1
Hi,

My i9 10900K is boosting to 6.4Ghz all cores Idle 4.9Ghz by itself according to HWMonitor, I have not tried an overclock or changed the voltage.
This is happening when gaming the tempretures stay bellow 74oC. I don't want it boosting this high because it affects gameplay I feel a lag occur when its happening
could someone advice me how to get the CPU to stay stock recommended. I've tried reseting the bios clear and the bios is up to date. I've checked all PSU connection to PC.

Can someone tell me some settings to change in the bios that will lock the CPU to 4.9GHz all cores (default).

Specs:
  • Motherboard: Gigabyte Z490 Vision G (3 Year Old)
  • CPU: i9 10900K (3 Year Old)
  • RAM: 32GB 8x4 Patriot Viper Steel 4400Mhz DDR4 @3866 (6 Month Old)
  • GPU: Zotac Trinity Gaming RTX 3080ti OC (1 Month Old)
  • PSU: Corsair 1200Watt (6 Month Old)
  • Storage: Samsung Evo 970 NVME 1TB (6 Month Old)
  • Cooler: Aurous 360 AIO (3 Year Old)
 

eL3ctro

Distinguished
Apr 17, 2015
87
0
18,640
1
Look at what's going on using CPU-z or HWiNFO. It's likely a software issue with trying to determine the clock speed the CPU is currently running at.
I'll give it, in the meantime is there anything I can change in the bios recommended from default for gaming with my setup want to get the best peformance,
 

Inthrutheoutdoor

Reputable
BANNED
Feb 17, 2019
255
66
4,790
6
Something is seriously amiss here, and I'm pretty sure it's software related, as in not correctly reporting the cpu speeds, cause even if you are running an LN2 cooling system on that machine, a 10 series cpu aint neva, eva gonna get nowhere near 6.4ghz.....if it did, it would draw so much power that your mobo would probably start melting and/or catch fire rather quickly....

in fact, in the past 30+ year history of modern pc's, there have only been an extremely limited number of cpu's that could go anywhere near that speed in very tighly controlled lab environments...
 

eL3ctro

Distinguished
Apr 17, 2015
87
0
18,640
1
Something is seriously amiss here, and I'm pretty sure it's software related, as in not correctly reporting the cpu speeds, cause even if you are running an LN2 cooling system on that machine, a 10 series cpu aint neva, eva gonna get nowhere near 6.4ghz.....if it did, it would draw so much power that your mobo would probably start melting and/or catch fire rather quickly....

in fact, in the past 30+ year history of modern pc's, there have only been an extremely limited number of cpu's that could go anywhere near that speed in very tighly controlled lab environments...
I don't think it is true but I believe the cpu may be pulling extra power / to much creating these false results in observations in CPU-Z, my cpu is boosting to 5.4Ghz all cores which is possible? but like I said I don't want it running higher than default
 

Inthrutheoutdoor

Reputable
BANNED
Feb 17, 2019
255
66
4,790
6
I don't think it is true but I believe the cpu may be pulling extra power / to much creating these false results in observations in CPU-Z, my cpu is boosting to 5.4Ghz all cores which is possible? but like I said I don't want it running higher than default
5.4Ghz and 6.4Ghz are 2 totally different thresholds.....

The former has been attainable for a few years now (toward the last of the gen 9's), so yes, a gen 10 cpu could reach that speed with the right tweaking and proper cooling.

My son's gammin rig is running with an i9-9900k @5.2ghz with an 360mm push/pull AIO setup & 9 case fans for almost 3 years now....with a full water loop it could probably do 5.4, but we don't have that equipment, so that's as far as I want to push it...

The latter, not so much, as I stated before..
 
Oct 23, 2022
50
1
35
0
Go to your bios. Set CPU ratio to 50 (5Ghz) or whatever you want it to be. Then, right below it, the CPU ratio mode should appear. Set it to FIXED. Now scroll down, find DigitALL power, and set CPU Loadline Callibration Controll to mode 4, which is a flatline ie what you want for stable perfomance. There's also voltage settings, but since your temps are normal you can prly leave it on auto. But just as a not MSI recommends using +-1.3 watts for 5Ghz overclocking and to never go beyond 1.4 watts. That may damage your components. All in all that will prevent any Ghz fluctuations and will keep it "steady".
You can also watch this little video. Start from 43:32 mark. The segment is only 3 minutes long so don't worry you don't have to watch the whole thing. It'll teach you all you need to know how to overclock your cpu on z490 series.
 
Last edited:

Zerk2012

Titan
Ambassador
I don't think it is true but I believe the cpu may be pulling extra power / to much creating these false results in observations in CPU-Z, my cpu is boosting to 5.4Ghz all cores which is possible? but like I said I don't want it running higher than default
Download OCCT and run the basic stress test and see what it says it's boosting to.
 

Eximo

Titan
Ambassador
I suggest not giving such blanket advice, particularly if your terminology is wrong. A 5Ghz all core is actually kind of bad, considering that by default you will have 2 cores reach 5.3Ghz, and multiple cores in decreasing clock speeds. Games typically won't stress all cores.

+-1.3 watts is meaningless. Should be Up to 1.3 volts. +- indicates that you have 1.3 volts up or down you could go, which is insanity.
 

ASK THE COMMUNITY