• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question i9 10900k running hot while being liquid cooled

Rooberrrt

Honorable
May 16, 2015
15
0
10,510
0
My PC rig:

Intel Core i9-10900K 3.7 GHz 10-Core Processor
NZXT Kraken X63 RGB
Asus ROG STRIX Z490-E GAMING
Corsair Vengeance RGB Pro 32 GB (4 x 8 GB) DDR4-3200
Samsung 980 Pro 1 TB M.2-2280
Gigabyte GeForce GTX 980 Ti 6GB
Corsair HXi 1200 W
Fractal Design Meshify S2 ATX Mid Tower Case

I've built this PC around 3 months ago and I started noticing a RED light popping up on my motherboard once in a while if I was either gaming or having multiple chrome tabs open.
I downloaded NZXT Cam to tweak the lights on my X63 and I noticed the CPU Fan says "n/a": View: https://i.imgur.com/eq3Zch2.png


My fans start too make a lot of noise when I start gaming, like a lot. So I downloaded the program from Asus called Al Suit 3 and I set the speeds on my fans to silent. (Which worked up until yesterday)

Now I'm just left with a PC that is making a lot of fan noise without even being under full load. If I'm doing basic tasks the temperature is anywhere from 45-50 degrees and when I go gaming it gets up to 80+ degrees (with the fans going full speed somehow)

I really don't know what I can do about this problem, hope someone has an answer! (Also want to know how I can fix the RED light that pops om somewhere here: View: https://i.imgur.com/MttZaUG.png
)
 

Rooberrrt

Honorable
May 16, 2015
15
0
10,510
0
* Remember a water cooler takes about 15 minutes to settle itself down to a constant temp after starting from a cold/off pc. But it shouldn't jump up to 80c right away, you may have a pump problem. After running the cooler for a while feel the tubes coming out from the pump. Are they both hot, both cold, or one hot and one cold?https://prnt.sc/1b4ctfw
They are both cold, I've changed the cooling to Performance and this is what I have right now with Chrome tabs + Spotify open:

After 15 minutes of changing: View: https://i.imgur.com/R6PmAlc.png


Fans or pump still makes a noticable noise. Can't really tell if it's fans or pump but I think pump
 
Ok so does the temperature stay low now when under load or does it still go up to 80c? And are you still getting the rec cpu warning light now? Experiment with the pump setting, set it to quiet to see if that is where the noise is coming from. Also see what happens with temp when pump is on silent under load.
 

Rooberrrt

Honorable
May 16, 2015
15
0
10,510
0
Ok so does the temperature stay low now when under load or does it still go up to 80c? And are you still getting the rec cpu warning light now? Experiment with the pump setting, set it to quiet to see if that is where the noise is coming from. Also see what happens with temp when pump is on silent under load.
It goes up to 70 degrees even without gaming now, I only have Chrome tabs open. Red light just showed twice when I opened a new Facebook tab.

I tried playing around with the cooling on the pump but I have seen no differences so far. Pump RPM ranges from 2100-2700
 

ASK THE COMMUNITY