Question i9-10900K Stuck at 4.9 GHz In-game and in Benchmarks

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
I just upgraded to an i9-10900K and an MSI Z490 Gaming Plus Mobo. Intel claims that the chip can go up to 5.3 GHz, but I've yet to see that in-game or in benchmarks. It never seems to go above 4.9 GHz.

Any thoughts? Is it a setting in the BIOS? A power limiter of some kind maybe?
 

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
Also if you have decent cooling remove any power limits or enable multi-core enhancement...not sure on a MSI board as I use Gigabyte board.
I’ve managed to over lock it so that all cores are running 5.3 GHz, but it’s running the OC all the time now. I know you said you use Gigabyte, but you wouldn’t happen to know how to make it so it’s dynamic/adaptive (not sure if using the right terms there)?
 
Are you running the 'Balanced' profile for power in Windows 10 under Power Option (Control Panel and the Power Options)? When running balanced mode the speed will drop when the load is low....Let me know and if that does not work we will look at other areas around your BIOS settings.
 

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
Are you running the 'Balanced' profile for power in Windows 10 under Power Option (Control Panel and the Power Options)? When running balanced mode the speed will drop when the load is low....Let me know and if that does not work we will look at other areas around your BIOS settings.
I'm running "Ultimate Performance". I got some help and changed the min and max power state to 5% (from 100%) and 100% respectively. It goes across the entire spectrum of frequencies now when idle which is what I would have expected it to do.

So that's sorted. But my original problem stands - none of the cores ever go above 4.9 GHz while under load. This might have something to do with the BIOS "Turbo Ratio Offset" where it designates 6 to 10 cores to run at 4.9 GHz, 4 to 5 cores at 5 GHz, 2 to 4 cores at 5.1 GHz, and 1 to 2 cores at 5.3 GHz. It's funny how none of the cores go above the slowest offset.

Edit:
I just left my PC at idle for a bit while doing something else and came back to see HWiNFO actually recorded 2 cores hitting a max of 5.3 GHz, and a few others hitting 5.1 and 5.0 GHz. Wait, does that mean the CPU only hits higher speeds while idle/no load instead of under load???
 
Last edited:

Turtle Rig

Prominent
Jun 23, 2020
540
63
490
8
I'm running "Ultimate Performance". I got some help and changed the min and max power state to 5% (from 100%) and 100% respectively. It goes across the entire spectrum of frequencies now when idle which is what I would have expected it to do.

So that's sorted. But my original problem stands - none of the cores ever go above 4.9 GHz while under load. This might have something to do with the BIOS "Turbo Ratio Offset" where it designates 6 to 10 cores to run at 4.9 GHz, 4 to 5 cores at 5 GHz, 2 to 4 cores at 5.1 GHz, and 1 to 2 cores at 5.3 GHz. It's funny how none of the cores go above the slowest offset.

Edit:
I just left my PC at idle for a bit while doing something else and came back to see HWiNFO actually recorded 2 cores hitting a max of 5.3 GHz, and a few others hitting 5.1 and 5.0 GHz. Wait, does that mean the CPU only hits higher speeds while idle/no load instead of under load???
Depends.... If you put 100 percent load then it must reduce all the cores speeds. But if your gaming or using a app or in Windows doing stuff and not rendering or running benchmarks then you will see a core at 5.3Ghz and 5.1Ghz and 5Ghz and 4.9Ghz. This is the way you want it as when you game it will use 2 cores at 5.3Ghz and 5.2 or 5.1Ghz and the rest of the cores wont be in use so it doesn't matter they stand clocked at 4.9Ghz and what not. Hope this makes sense. The 10900k will never go above 25 percent usage gaming or doing other tasks. Especially the fact most apps and Windows depend on single core speed. So for that 25 percent you will get the 5.3Ghz and 5.2Ghz. The rest of the cores would not be in use so it really doesn't matter and I don't suggest trying to overclock so all cores are at 5.3Ghz as that will cause a crash most likely and also you will need beefy liquid cooling as the temps will go near 100c and what not.
 

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
Depends.... If you put 100 percent load then it must reduce all the cores speeds. But if your gaming or using a app or in Windows doing stuff and not rendering or running benchmarks then you will see a core at 5.3Ghz and 5.1Ghz and 5Ghz and 4.9Ghz. This is the way you want it as when you game it will use 2 cores at 5.3Ghz and 5.2 or 5.1Ghz and the rest of the cores wont be in use so it doesn't matter they stand clocked at 4.9Ghz and what not. Hope this makes sense. The 10900k will never go above 25 percent usage gaming or doing other tasks. Especially the fact most apps and Windows depend on single core speed. So for that 25 percent you will get the 5.3Ghz and 5.2Ghz. The rest of the cores would not be in use so it really doesn't matter and I don't suggest trying to overclock so all cores are at 5.3Ghz as that will cause a crash most likely and also you will need beefy liquid cooling as the temps will go near 100c and what not.
That makes sense - I would only need 1-2 cores running at the turbo boost for my daily use. And I wouldn't care about the other core speeds. But so far, none of the cores have ever reached higher than 4.9 GHz while gaming.
 

Turtle Rig

Prominent
Jun 23, 2020
540
63
490
8
That makes sense - I would only need 1-2 cores running at the turbo boost for my daily use. And I wouldn't care about the other core speeds. But so far, none of the cores have ever reached higher than 4.9 GHz while gaming.
Hmmmmm. I would go to the BIOS and restore to optimal values or reset it. Just make sure turbo 2.0 and 3.0 are on and multithread enhancement is set to on and you should be good. Get back to me on this note. ;)
 

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
Hmmmmm. I would go to the BIOS and restore to optimal values or reset it. Just make sure turbo 2.0 and 3.0 are on and multithread enhancement is set to on and you should be good. Get back to me on this note. ;)
I reset the BIOS and these are my Turbo Options:
https://drive.google.com/file/d/1B3f02XuRqd5JVDPVRphenEs2YlgEdv5a/view?usp=sharing
Unless I am totally misunderstanding this, the minimum turbo is 4.9 GHz, and the max turbo (for at least 1-2 cores) should be 5.3 GHz. But all the cores are Turbo Boosting to the lowest turbo and not higher for some reason while under load.

If I open up the CPU specific options:
https://drive.google.com/file/d/1KT5X4BWhZJiORRJqPIqamnXfLT1NdSom/view?usp=sharing
I don't see anything resembling "Turbo 2.0" or 3.0. And if I recall, I don't believe MSI has "Multithread Enhancement". Unless it's "Per Core Hyper-Threading Control" here?
 
Last edited:

mdd1963

Champion
To be clear/to clarify, you are not going to see 1-2 cores at 5.3 GHz, and yet still the remainder of the cores at 4.9 GHz...

If inducing an all- core loading, you are going to see only 4.9 GHz...

The best way to see single core loading scenario is to just open HWMonitor, and then surf the web, hardware forums, open/close a few apps. Then you ought to see at least one or two cores hit near max turbo, i.e., 5100-5200 MHz or so, at least for a fraction of a second to a second or so, before idling back down when in Balanced Mode power plan ....
 

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
To be clear/to clarify, you are not going to see 1-2 cores at 5.3 GHz, and yet still the remainder of the cores at 4.9 GHz...

If inducing an all- core loading, you are going to see only 4.9 GHz...

The best way to see single core loading scenario is to just open HWMonitor, and then surf the web, hardware forums, open/close a few apps. Then you ought to see at least one or two cores hit near max turbo, i.e., 5100-5200 MHz or so, at least for a fraction of a second to a second or so, before idling back down when in Balanced Mode power plan ....
But typical gaming/bench-marking applications only use up at most 2 cores though right? So shouldn't those 1-2 cores be running at 5.3 GHz according to my BIOS settings? https://drive.google.com/file/d/1O6MvDVD2ufcGk_JUlPjHr1emKvL1KvfV/view?usp=sharing

While I was AFK, I did see the max frequency of 2 cores hit 5.3 GHz, but this was while idling. I want that while gaming/bench marking/under load. In which case, I've yet to see a single core go over 4.9 GHz. It doesn't seem that helpful if it hits a higher frequency while I'm not doing anything...
https://drive.google.com/file/d/1zBMT6I-s6xQQm7PIQNXibLahdeRf57vV/view?usp=sharing
(Not the same instance, but I was able to catch it - this was while idling on desktop)
 
Last edited:

Turtle Rig

Prominent
Jun 23, 2020
540
63
490
8
But typical gaming/bench-marking applications only use up at most 2 cores though right? So shouldn't those 1-2 cores be running at 5.3 GHz according to my BIOS settings? https://drive.google.com/file/d/1O6MvDVD2ufcGk_JUlPjHr1emKvL1KvfV/view?usp=sharing

While I was AFK, I did see the max frequency of 2 cores hit 5.3 GHz, but this was while idling. I want that while gaming/bench marking/under load. In which case, I've yet to see a single core go over 4.9 GHz. It doesn't seem that helpful if it hits a higher frequency while I'm not doing anything...
https://drive.google.com/file/d/1zBMT6I-s6xQQm7PIQNXibLahdeRf57vV/view?usp=sharing
(Not the same instance, but I was able to catch it - this was while idling on desktop)
This is normal my old mans 9900k behaves the same way. You should have a option to set the turbo X multiplier so make sure say core 1 is 53x and core 2 be 52x core 3 be 51x and rest of cores be 50x ....... Im not to familiar with MSI BIOS but it is a darn good company so you should be able to do this.
 

halo35boy

Honorable
Jan 1, 2014
70
0
10,540
3
This is normal my old mans 9900k behaves the same way. You should have a option to set the turbo X multiplier so make sure say core 1 is 53x and core 2 be 52x core 3 be 51x and rest of cores be 50x ....... Im not to familiar with MSI BIOS but it is a darn good company so you should be able to do this.
Thanks for your help regardless. I really appreciate it.

So I did find a "Per Core" option in the BIOS. I set it up to look like this:
https://drive.google.com/file/d/1ZVmJ_4Uh3fc3J0IynVzG_oI4xJfo79ei/view?usp=sharing
While under load, none of the cores went higher than 4.9 GHz for some reason.

Then I tweaked it to this:
https://drive.google.com/file/d/1EzrVVUyJOx9oplWmvKqM91260sgJ1CiH/view?usp=sharing
Now nothing goes above 3.7 GHz...

Then I went back to the default "Auto":
https://drive.google.com/file/d/1eNmIhxpFvyTRz12QzlmkkJLa_NIuJgGi/view?usp=sharing
And again, nothing went above 4.9 GHz.
 

Turtle Rig

Prominent
Jun 23, 2020
540
63
490
8
Thanks for your help regardless. I really appreciate it.

So I did find a "Per Core" option in the BIOS. I set it up to look like this:
https://drive.google.com/file/d/1ZVmJ_4Uh3fc3J0IynVzG_oI4xJfo79ei/view?usp=sharing
While under load, none of the cores went higher than 4.9 GHz for some reason.

Then I tweaked it to this:
https://drive.google.com/file/d/1EzrVVUyJOx9oplWmvKqM91260sgJ1CiH/view?usp=sharing
Now nothing goes above 3.7 GHz...

Then I went back to the default "Auto":
https://drive.google.com/file/d/1eNmIhxpFvyTRz12QzlmkkJLa_NIuJgGi/view?usp=sharing
And again, nothing went above 4.9 GHz.
Hmmmmm that is weird. There has to be a option in the BIOS somewhere something smells fishy. Hopefully someone with your motherboard or experience with MSI motherboards can shed some light.
 
Reactions: halo35boy

ASK THE COMMUNITY