I9-900k with 2080. Drop frames in game

MEPC1982

Commendable
Mar 12, 2016
4
0
1,510
0
I’m having issues with the games frames dropping drastically.

My rig is a i9-9900k on an Asrock taichi with a Gygabyte 2080 Xtreme. 16 GB ram and 2 250Gb mnve samsung evo in raid 0. Psu evga Supernova Gold 750w

I’m not overclocking just using the asrock app and set to performance.

I’m playing Battlefield V At recomended settings by Nvidia expirience. At 1440 hz. It plays nice mostly. But suddelly the frames drop from steady 70-90 to 15-20 for few seconds. It is frustrating. Idk if it is my systems or it is just normal. Temps are in the 60s-70s. Any idea what it maybe issue? Bottleneck some where? Thanks in advance
 

SkyRock1986

Great
Feb 28, 2019
182
9
95
0
Couple things here boss, First you should not be dropping frames with that sort of hardware. I want to know what monitor are you using? Are you using G Sync? Are your settings in your nvidia settings set to let application decide, and your game is controlling your refresh rate? I believe you probably have a contradicting setting perhaps
 
But suddelly the frames drop from steady 70-90 to 15-20 for few seconds.
Yeah this has nothing to do with vsync or the likes..
Also why are you getting only 70-90 FPS?!?! The settings nvidia applies are probably way too high I would try using the games presets.
I have no idea what the asrock app set to performance does,so check your clocks while gaming, the app might be overclocking your CPU without your knowledge.
Also you should check if this FPS drop has something to do with your internet connection,does it only happen at times when everybody is online or does it also happen early in the morning or late at night?
 
Feb 27, 2019
11
1
15
0
I’m having issues with the games frames dropping drastically.

My rig is a i9-9900k on an Asrock taichi with a Gygabyte 2080 Xtreme. 16 GB ram and 2 250Gb mnve samsung evo in raid 0. Psu evga Supernova Gold 750w

I’m not overclocking just using the asrock app and set to performance.

I’m playing Battlefield V At recomended settings by Nvidia expirience. At 1440 hz. It plays nice mostly. But suddelly the frames drop from steady 70-90 to 15-20 for few seconds. It is frustrating. Idk if it is my systems or it is just normal. Temps are in the 60s-70s. Any idea what it maybe issue? Bottleneck some where? Thanks in advance
Hello there,

I was looking your post and I think the problem here are the graphics drivers that they are not updated.

Here I leave you the link to update the latest drivers for your RTX 2080 graphic card.

https://www.nvidia.co.uk/Download/driverResults.aspx/143333/en-uk

Note: I would rexommend you to download DDU which you will be able to uninstall the current drivers you have and then install the new drivers. It includes a guide of how to use it.


https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
 

ASK THE COMMUNITY

TRENDING THREADS