[SOLVED] i9700k making noises?

Jan 30, 2019
4
0
10
0
Since I changed the configuration with an i7 9700K and a Aorus Z390 PRO I noticed terrible electrical noises from the power supply. I thought the problem was mine CX750M 80 Bronze but I tried to change it with another 750M and the noises remained there. At this point I really don't know how to eliminate these horrible sounds from my case, they are such frustrating. The only thing I can assume is that the 8-pin cpu cable is not enough, and if I add the other 4 (so 8 + 4) the load is managed in a more optimized way. Any help? Thank you in advance.
 

jankerson

Judicious
BANNED


Replace the PSU with a good quality unit.

The CX750M is NOT a good PSU.

750W is good.

Seasonic Focus Plus
EVGA G2 or G3
Corsair RMX
 
Jan 30, 2019
4
0
10
0


Hi winks. I don't know how to explain it properly. It's just a persistent sound: it starts from the mobo logo and it ends when I turn off the PC. I didn't find any videos on youtube like my sound.. I'll try to record it but is hard because I've 9 fans in the whole pc. I'm 100% sure is the PSU because I also tried with another one outside the case and it still there.

 

taeioum

Respectable
Can you see if there's a tiny fan under the I/O shroud? I returned a AORUS Z370 Gaming 7 after a couple hours because there was a tiny (25-30mm) fan under the I/O shroud.

I can't seem to find out if there's on on this Z390 PRO board and I honestly doubt there is, since the I/O shield (not the shroud!) is preattached.

Just something to keep in mind.
 

jankerson

Judicious
BANNED


Replace the PSU with a good quality unit.

The CX750M is NOT a good PSU.

750W is good.

Seasonic Focus Plus
EVGA G2 or G3
Corsair RMX
 

ASK THE COMMUNITY

TRENDING THREADS