Question ICC Profile keeps resetting

Status
Not open for further replies.

elijah_

Distinguished
Oct 1, 2012
67
0
18,530
0
Hi,

I built a new PC last week and ran into a bunch of issues but one of the last I haven't been able to solve is that my ICC profile keeps resetting after every reboot. I clicked through dozens of posts about this problem but none of the solutions I found have worked for me so far. Things that I have tried include:
  • updated Windows all the way (v 1909)
  • set my .icm as default under Colour Management<Devices, as well as under <Advanced 'Device Profile' and <Advanced 'Change system defaults'
  • made sure Night Light is disabled
  • disabled WindowsColorSystem task schedules
Is there anything else I can try? I'm running a two monitor setup if that matters and am only using the .icm on my main monitor (Benq XL2411Z, which unfortunately really seems to need a profile because its colours OOTB depending on settings are either really washed out or really dark/poor contrasts). I followed this guide to set the monitor up, which I have done before. I've always had problems with loading these profiles every time I (re-)installed Windows on my old PC but always managed to make it load it after a few tries but I'm at my wits' ends here.

Thanks for any help!
 

Lutfij

Titan
Moderator
See if uninstalling the drivers for your display and then reinstalling them using the drivers, found here, helps. I would advise that you reinstall the drivers in an elevated command, i.e Right click installer>Run as Administrator.
 

elijah_

Distinguished
Oct 1, 2012
67
0
18,530
0
I uninstalled the device using the Device Manager and rebooted but don't know how to install the driver as administrator from here because they come as a .zip including a .cat, .icm and .inf-file.

I just installed them normally via the Device Manager which unfortuntaly didn't help. I still had to reload the ICC profile via colour management.
 
Last edited:

elijah_

Distinguished
Oct 1, 2012
67
0
18,530
0
I noticed there's in the Device Manager>Driver Details and in Colour Management>All profiles there's standard XL2411Z.icm listed that's probably installed as part of the original driver. Is it possible that this interfere's with the one I added? Is there maybe another way to override this? Can it just be deleted or replaced? It's located in system32 so not sure I'd want to mess with it...
 
Nov 12, 2020
1
0
10
0
I got the same problem and I think I already solved it. Was by mistake, but I found a solution. In the Search Bar in Windows 10 just type "size", and then click on "Change the size of text, apps or other items" . A new window pops up, so, at the left side of that window click on "Display", then at he right side you will see "color profile". Choose the color profile you want. I dont know why in color adjustments Windows dont take the default color profile I set. But doing here it will fix the switching between other profiles. Good Luck! I hope it helps to you.
 
Last edited:
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS