ICS gateway reboots when connecting to an FTP



Well, I'm currently sharing my connection with 2 other computers, the cable modem connects to a win2000 sp2 machine that has two NICs: One SMC, the other Macronix based.

My problem is that when I attempt to connect to >SOME< ftps, either through a client PC or the gateway itself, the gateway reboots automatically.

Upon checking the event viewer, this is what is logged:

The computer has rebooted from a bugcheck. The bugcheck was: 0x0000000a (0x804b1e38, 0x00000002, 0x00000000, 0x804b1e38). Microsoft Windows 2000 [v15.2195]. A dump was saved in: C:\WINNT\Minidump\Mini041802-01.dmp.

I figure it's some kind of IRQ conflict or something or other, but I could sure use some suggestions as to troubleshooting this.

My gateway has this hardware in it:

WD 1.6gb HDD
Macronix based NIC
Matrox Mystique 2mb (oh the power!)
Acer 12x cdrom
Generic FDD

I used to have a SB16 in it and tried taking it out but it didn't resolve the problem.

From looking in the Device Manager, the IRQs are as follow:

(ISA) 0 System timer
(ISA) 1 PC/AT Enhanced PS/2 Keyboard (101/102-key)
(ISA) 3 Communications Port (COM2)
(ISA) 4 Communications Port (COM1)
(ISA) 6 Standard floppy disk controller
(ISA) 8 System CMOS/real time clock
(ISA) 12 Microsoft PS/2 Mouse
(ISA) 13 Numeric data processor
(ISA) 14 Primary IDE Channel
(ISA) 15 Secondary IDE Channel
(PCI) 5 Macronix MX98715 Family Fast Ethernet Adapter (ACPI) #2
(PCI) 9 SMC EZ Card PCI 10 Adapter (SMC1208)
(PCI) 11 Matrox Mystique PCI - English


You said this happens when you connect to >SOME< FTP sites - is there any way to filter out what the OS is of the sites you're connecting to? I've seen some pretty cludgy stuff in my day with certain flavors of Solaris and how Windows machines connect to it. Also, what is your FTP client software? Are you going through a switch or a hub, and what are the speed settings? Have you tried keeping the FTPing just local to see if that reproduces the problem? Does it happen with any other TCP protocol? Have you tried making a UDP connetion on port 21?

I know that's a mouthfull rightnow, but I figure brainstorming this is the only way we're gonna help you solve it!

Check out the BIG Baseball League, the #1 Baseball Mogul (tm) Simulation league on the internet!