IDE to SATA Adapter

Dominaz1

Distinguished
Dec 31, 2010
219
0
18,710
Hello, I´ve just made a new rig, with a ASRock H61M-VS and a Celeron G530.
I would like to use an old 40 Gb IDE hard drive, so I bought an adapter, the problem is that It doesn´t work.
Should I change any parameter into the BIOS?

Thank you-!
 

Delirious788

Distinguished
Sep 29, 2011
247
0
18,710
What IDE to SATA adapter did you buy? I had a couple of those in my old PC and the manual with it was useless. The jumper settings were all wrong in the manual. I would suggest doing a little googling and reading reviews to see if others figured out how to get it to work.

You shouldnt need to change anything in the BIOS.
 

ringzero

Distinguished
Dec 7, 2011
320
0
18,810
I don't have much good advice. I DID manage to use an IDE to SATA adapter on an old Hitachi 250GB HDD and got it to work. Problem was, it was SOOOOO slow and I couldn't even get the cover back on my case because the adapter stuck out so far.

I dumped that old HDD. Think about getting a 60GB SSD for around ~$60 or a 1TB drive for ~$110.


Could you also be more specific on "it doesn't work?" It took a bit of messing around in drive management for me to get mine to be recognized.
 

Delirious788

Distinguished
Sep 29, 2011
247
0
18,710
I think you still need to power the HDD up with the Molex power connector. That one is different from the ones I used and yeah, it is going to slow down the HDD a TON. It is really hard to justify using them. After about a few months with them, I decided to just upgrade my HDD to SATAs. I would be careful and try every configuration of plugging things in, trying different cables. Other than that it doesnt look like you have any jumpers to messs with so I don't know what else to tell you. If that doesnt work then maybe cut your losses and get a new HDD/SDD.