I'm at a school dorm and I have a problem with my laptop. My xbox connects fine

11jvann

Honorable
Jan 9, 2013
9
0
10,510
Hello,I'm at a school dorm and I have a problem with my laptop. My xbox connects fine with wireless and the ethernet cord. but my laptop doesn't My laptop gets wireless but when I plug the ethernet cord in im connected to a network it says I have internet but when I try to go to google or any webpage nothing loads just white page. I try to play a game like Diablo 3 but some reason its not getting the connection to the internet. My port is fine on my computer so i narrowed it down to be wrong with my computer.
 
Solution
My only other idea currently is after you use the wireless to download the latest LAN adapter driver (make sure it is for your version), go into the device manager and uninstall the Ethernet adapter. Then restart and let it reinstall, providing the driver as needed.

11jvann

Honorable
Jan 9, 2013
9
0
10,510



it was working a few days ago and it says its up to date. There has to be something blocking the access or something.
 

RealBeast

Titan
Moderator
Did you install any new software or update any, like iTunes?

I would also open the adapter properties in the network control panel and see if anything for the Ethernet adapter has changed, including the automatic IP addressing (right click the adapter in change adapter settings, highlight Internet Protocol Version 4 and hit properties).
 

11jvann

Honorable
Jan 9, 2013
9
0
10,510


I just did that and nothing has changed. Thanks for helping me btw :). This is one tough cookie lol.
 

RealBeast

Titan
Moderator
Next, I would reset the adapter, just disable and then re-enable it in the network control panel; and then run the troubleshooter on it.

Also, reset the TCP/IP stack to default by opening the command prompt with a right click run as administrator and type: netsh int ip reset c:\resetlog.txt

Reset winsock next by typing: netsh winsock reset ; Then reboot.

If those don't fix it, I would try another DNS server, like 8.8.8.8 (the Google public DNS), for the Ethernet adapter, same spot as where you checked the automatic IP address.
 

11jvann

Honorable
Jan 9, 2013
9
0
10,510


I tried all that you mentioned. Still can't load up the page or do anything internet related. It looks like its about to load but then it doesn't
 

RealBeast

Titan
Moderator
My only other idea currently is after you use the wireless to download the latest LAN adapter driver (make sure it is for your version), go into the device manager and uninstall the Ethernet adapter. Then restart and let it reinstall, providing the driver as needed.
 
Solution

11jvann

Honorable
Jan 9, 2013
9
0
10,510



here :


IPV4 Address: 10.67.195
IPV4 subnet mask: 255. 255.252.0
lease times: Jan 9 4:20 expires feb 08 2013
IPV4 default gateway 10.67.16.1

it showed stuff like that yes.



 

11jvann

Honorable
Jan 9, 2013
9
0
10,510


Well thanks for the help anyways. I have actually tried that. I know some basic stuff lol :). Well I know something is blocking the internet to be used on my computer. I know its somethign about my computer. It says I have internet access I just don't know what it is. I looked at services and it seems good there. I just have no clues. You have any ideas what I should do like to take it somewhere to have it looked or something lol.
 

11jvann

Honorable
Jan 9, 2013
9
0
10,510


well I did something and after 2 days it finallyw orks lol. Thank you for your help :) its greatly appreciated :) sorry to waste your time like that. Hope you have a great day