Question I'm facing very strange lagging with my new HDD ?

May 25, 2021
2
0
10
0
Hello everyone! Gotta apologise for my bad english beforehand, but i'm kind of desperate and have to seek help from english speaking friends :)

So, i assembled my new PC around 2 years back, with only SSD and the OS on it, and up untill this point everything was okay. But as you know, nowadays new games are very heavy so i pondered about getting a new 1tb HDD .

After getting one and installing into my PC and downloading bunch of games (RDR2, rainbow six, cs go) from steam i faced some very strange lags that resemble more like i'm having high ping but my internet connection is fine. The ping in aforementioned games is fine, around 15 to 45 ms also this problem persist in single player games as well. The pattern of the lags as i said before is very similar to high ping, specifically: some textures are dissapear and reappear after a few seconds, or the sound of footsteps dissapear as well or gun shots etc. But the strangest thing most games have in common is interface dissapearing or some parts of it. For example in rainbow six after round starts, the icons of players and the timer dissapear for 5-10 sec and then appear again.

The same thing goes for RDR2, the crosshair dissapear after i pull out and point my gun or mini-radar goes off the screen with the other parts as ammo info, money stats etc. Also some npcs ride invisible horses, or i lose control over my player and get it back after 5 sec.

But overall perfomance in these games (rainbow six, rdr 2) is seems pretty fine. The fps holds stabily at 60 fps and doesn't tend to drop. No spikes, lags and all of that.
But in cs go everything is different and it's lags asf every god damn second.

So i thought i got corrupted HDD i already wanted to grab it and take it back to the shop, but then i remembered about my old HDD from my old pc, so i got it into my pc and installed the same games and got the same thing. So what i already it is i changed sata jack/nest/socket (idk what you call it in english) on my motherboard and got zero results. Also changed sata cable and the same..

After some time of tinkering with this mess i dropped it and went to play some games from my SSD and got the same problem with SSD! I promptly disconnected HDD from my PC and after that everything was fine.

So main point that i took away from all this situation is, it's seems my pc have troubles with running HDD and i don't know what to do with that. I did some digging on the interted and found similar questions, but doesn't seem that the problem solved.
Also linking some videos of my gameplay with these lags from all three games i mentioned:

https://www.youtube.com/watch?v=4TykbLwW4Nk
https://www.youtube.com/watch?v=9Q7Rk0t7cDs
https://www.youtube.com/watch?v=KLaM_kj571Q
 
Last edited:
May 25, 2021
2
0
10
0
could just be the game getting data from the hdd. check the hdd usage?
defrag the drive?
replace it with ssd?
Getting data from the hdd? not really sure what do you mean, the games that lag are already on hdd
i don't think there is any sense do defrag brand new hdd, i checked the condition in progs like crystaldiskinfo and it was alright so.. Also it's would be a quite strange coincidence that the two HDD lag simultaneously and have the same issues
Well SSD are pretty expensive that's why i chose to get HDD instead.
 

ASK THE COMMUNITY