• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question I'm getting graphics lag/stutters.

ricky_skyline

Distinguished
Apr 1, 2013
15
0
18,510
0
This is my Rig: https://pcpartpicker.com/user/rskyline/saved/3KjmkL

I first got a strix 5700 xt and of course is a beast but it kinda overheats, so I though the lag was related to that, so I went and change it for a Nitro+, because everyone says is the best out there. But I'm still getting lag.

I tried to use DDU twice, tried using Radeon software stable and beta and still the same. I don't want to format if it's not needed, but I can as a last resort.

Useful info: I upgraded almost every part on my system except for ram and storage, but I didn't format to do a clean install of windows.
 

poorbugger

Reputable
Nov 28, 2015
355
50
4,790
6
Okay the first thing everyone should keep in mind when buying ryzen cpu is that you need fast ram. 3000mhz is the minimum recommendation for the 3600. You can watch on youtube on how much difference does the ram speed make. I suspect the slow ram speed is what causes the stutters. Make sure you install the ram properly so you can get dual channel as well
 

ricky_skyline

Distinguished
Apr 1, 2013
15
0
18,510
0
Okay the first thing everyone should keep in mind when buying ryzen cpu is that you need fast ram. 3000mhz is the minimum recommendation for the 3600. You can watch on youtube on how much difference does the ram speed make. I suspect the slow ram speed is what causes the stutters. Make sure you install the ram properly so you can get dual channel as well
Could be, the weird part its that I've been using the ryzen for about a month and the issue just started like a week ago. And before it was working just fine. I was thinking more that not doing a clean install of windows (coming from Intel to ryzen I didn't clean install windows)
 

ASK THE COMMUNITY