Question I'm not able to connect to 2.4ghz ssid on a dual band router ?

Noobiness_Unlimited

Commendable
Jul 20, 2018
166
1
1,715
16
Hi all, I'm using a Jiofiber fiber Internet connection and have a Jio router for the same. It's a dual band router hence transmits both 2.4 and 5ghz frequencies for devices to connect to. I have a Samsung galaxy a7 tablet which supports both 2.4 and 5ghz frequencies but I'm only able to connect to the 5ghz ssid with it, meanwhile with my Motorola g4 play and Asus Zenfone max pro m2 which don't support 5ghz frequencies (so they don't even detect the 5ghz ssid), I'm not able to connect to the 2.4ghz ssid with either devices. Upon entering the password and pressing connect on all the previously mentioned devices, it shows "connecting" and then that changes to "saved", doesn't connect. I really need help with this issue. Also can it be because the password for both the ssids are same?
Thanks in advance
 

kanewolf

Titan
Moderator
Hi all, I'm using a Jiofiber fiber Internet connection and have a Jio router for the same. It's a dual band router hence transmits both 2.4 and 5ghz frequencies for devices to connect to. I have a Samsung galaxy a7 tablet which supports both 2.4 and 5ghz frequencies but I'm only able to connect to the 5ghz ssid with it, meanwhile with my Motorola g4 play and Asus Zenfone max pro m2 which don't support 5ghz frequencies (so they don't even detect the 5ghz ssid), I'm not able to connect to the 2.4ghz ssid with either devices. Upon entering the password and pressing connect on all the previously mentioned devices, it shows "connecting" and then that changes to "saved", doesn't connect. I really need help with this issue. Also can it be because the password for both the ssids are same?
Thanks in advance
Some devices DO have issues when the 2.4 and 5Ghz SSID are the same. It should be easy to test by setting them to unique values.
 

Mr.Spock

Commendable
Dec 8, 2019
998
108
1,390
96
some devices have problems connecting to SSIDs with special chars or mixed case, not sure if that's your issue - also make sure the router is set up as WPA2-AES - some devices won't connect to TKIP-enabled setups.
 

kanewolf

Titan
Moderator
Normally the channel is 6, I tried switching to 11 but it didn't help either.

P.S: I'm from India
OK. Not channel. Could be SSID name -- too long, or strange characters. Could be password -- Too long or strange characters, etc.
Could be encryption. If you aren't using WPA2, AES. Could be MAC filtering.
If all else fails, TEMPORARILY delete and create it as an unencrypted SSID and try.
 

Noobiness_Unlimited

Commendable
Jul 20, 2018
166
1
1,715
16
OK. Not channel. Could be SSID name -- too long, or strange characters. Could be password -- Too long or strange characters, etc.
Could be encryption. If you aren't using WPA2, AES. Could be MAC filtering.
If all else fails, TEMPORARILY delete and create it as an unencrypted SSID and try.
The password is the default password given from the isp, it is long and has numbers and letters but the 5ghz ssid has the same pass and it works fine thats why I didn't consider it, as for the ssid, its same for both but the 5ghz one has '_5g' at the end of the name. I'll check the encryption today later on and there's no Mac filtering. Also will try temporarily creating it as an unencrypted ssid.
 

ASK THE COMMUNITY

TRENDING THREADS