Question I'm not getting my full internet speed on ethernet.

Dec 28, 2022
I can't seem to be getting my full internet speed with an ethernet cable. I tied plugging the ethernet cable into a laptop right beside my desktop and the laptop was getting 1Gbps download and 30Mbps upload on the speed test. But when I try doing the same speed test from the same server on my desktop, I got 500Mbps download and 30Mbps upload. The speed test doesn't detect the 500Mbps directly. It starts at 60Mbps and starts climbing till the end of the speed test to reach 500Mbps. I tried booting up a live Linux disc to see if Windows was the problem, but it seems like it isn't. I then looked up my motherboard to see if it had an ethernet speed cap and it does, but at 1Gbps. It should be enough for my internet speed, right? If my motherboard isn't the problem then I don't know what is. I started a thread a few months ago and thought that the problem would be solved when I got a new motherboard, but the problem persists even after I upgraded. I also upgraded to windows 11 as my old motherboard didn't support it. The thread: . Here are my computer specs for you to see if anything catches your eye:

OS Name Microsoft Windows 11 Pro N
Version 10.0.22621 Build 22621
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-D594G2B
System Manufacturer To Be Filled By O.E.M.
System Model B660 Pro RS
System Type x64-based PC
System SKU To Be Filled By O.E.M.
Processor 12th Gen Intel(R) Core(TM) i3-12100F, 3300 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends International, LLC. 9.02, 3/29/2022
SMBIOS Version 3.4
Embedded Controller Version 255.255
BaseBoard Manufacturer ASRock
BaseBoard Product B660 Pro RS
BaseBoard Version
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume4
Locale United States
Hardware Abstraction Layer Version = "10.0.22621.1413"
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.8 GB
Available Physical Memory 25.3 GB
Total Virtual Memory 36.6 GB
Available Virtual Memory 28.2 GB
Page File Space 4.75 GB
Page File C:\pagefile.sys
Kernel DMA Protection On
Virtualization-based security Not enabled
Windows Defender Application Control policy Enforced
Windows Defender Application Control user mode policy Off
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Thanks in advance!🙂