Question Impossible to install windows 10 on an MSI x570-A pro

Aug 31, 2019
3
0
10
0
Hello everybody,
sorry to bother but I'm facing quite some problem.
I've tried to install windows 10 ver 1809 on the following system:
PSU silverstone sx700-LPT
MOBO MSI X570-A pro
2X8 GB Corsair Vengeance 3 Ghz
Ryzen 3600
1 Samsung SS 860 QVO
1 HD WD da 2 TB
MSI Vega 56

the problem is when I try to install windows 10, it pops a window where it states that a media driver your computer needs is missing, but I've tried to download all the driver of the motherboard from MSI website and non of them gets accepted to be used for the installation of windows.


now an other problem has added itself to the list, any time I turn on the computer the bios gets stuck on the Pro series logo and doesn't let me do anything refusing to accept any keyboard command.

hope you guys will help me because right now I'm stuck with some expensive bunch of crap as long as I can't make it work XD
 
Aug 31, 2019
3
0
10
0
download latest install media from MS website to a new usb flash drive and install from there
sorry I forgot to tell that before I've tried the version 1903 (the latest available on the MS website) and right now I can't even get to the installation, in fact I'm stuck on the Pro Series bios logo without the possibility to do anything ...
 
Aug 31, 2019
3
0
10
0
sorry I forgot to tell that before I've tried the version 1903 (the latest available on the MS website) and right now I can't even get to the installation, in fact I'm stuck on the Pro Series bios logo without the possibility to do anything ...
Update, I solved, eve I don't know how, the issue of the bios logo, now I'm still stuck with the media driver that will not be loaded in any case ... I've litterally tried everything, I even tried blocking the PCI-E gen 4 in the bios in order to cut the possibilities of interference but not step ahead has been made
 

ASK THE COMMUNITY

TRENDING THREADS