Question Infrared touchscreen overlay for PC is stuck in firmware upgrade mode ?

Jul 16, 2021
2
0
10
0
I have this infrared touchscreen overlay: https://cjtouch.en.made-in-china.com/product/iSzxwQrTuJtq/China-Interface-IR-Infrared-Touch-Screen-22-Touch-Screen-Overlay.html

I bought it a few years ago when I still used Windows 7. That OS has a bug where you can't disable a single click delay for touchscreens. I was trying to find some way to fix it and downloaded the drivers (even though this device doesn't require installing any drivers) from here: http://www.cjtouchscreen.com/download/c-1502530840
(CJTouch IR Touch Screen Driver T3,T99,T200(BNA2,CNA2))
When I downloaded this software I ran MTUsbUpgrade.exe

It put the touchscreen device in firmware upgrade mode:

In the PDF manual (inside that downloaded zip folder) it's said that I need a .bin file to upgrade the firmware. When I click "Leave Upgrade Mode" it says "Failed to leave upgrade mode, please check!".

Since then the device has no longer worked.
The touchscreen doesn't have any buttons, only a USB cord.
Is there any way to make it work again? Or the only way is to contact their support and ask for the .bin file?
 
Last edited:
Thread starter Similar threads Forum Replies Date
Kasko Computer Peripherals 0

ASK THE COMMUNITY

TRENDING THREADS