[SOLVED] Input delay on windows ten after factory reset

Jan 20, 2021
18
0
10
0
Recently i was having problems with my two monitor set up cos i was making my monitor 60hz so i was forced to factory reset my pc. Having factory reset my pc, I Opitmized it and installed the latest drivers but for some reason when playing games( namely fortnite) I have been feeling a ton of input delay. my aim seems unaffected but it feels like its my keyboard that feels delayed ( Im not sure tho). I checked the input delay with latency markers in fortnite and it said it was 8 ms which is weird cos my game feels near unplayable. Could this be cos its my keyboard that is causing the input delay any tips would be appreciated
 

Colif

Win 10 Master
Moderator
So no AMD power plans?


if you don't, perhaps you need to update some more drivers.

Is this the board? https://www.gigabyte.com/au/Motherboard/B450-Gaming-X-rev-1x/support#support-dl-utility
I can only see one Gigabyte gaming board. Did you install the Gigabyte App centre as I know it updates drivers (it can be tricky to use, it highlights all the apps which aren't really useful. or needed). I have a Gigabyte motherboard myself.

if you run it, the first screen just shows installed apps, you need to click the Live update button to get updates. (I have it highlighted in below photo, mouse cursor not shown in screenshot), then on next screen, click the orange tick above the rest of the individual ticks to deselect.


Its tricky as you need to scroll down as there is another section below for 3rd party software and you probably don't want it
You really only want drivers


I am currently up to date so can't show what drivers look like.

you might need to get chipset drivers from https://www.amd.com/en/support/chipsets/amd-socket-am4/b450 to get the AMD power plans, but Gigabyte App might update them for you.

also what should i try for another USB Slot
i mean plug KB into another USB slot.

I have to go but will look in here later. Its 4.30am here.
 
Last edited:
Jan 20, 2021
18
0
10
0
Mine is 1904.746 i think. for some reason my dad dislikes me updating my windows cos he says that it can cause issues. im not sure i agree with him
 

Colif

Win 10 Master
Moderator
19041 or 19042?
not a great difference, 19042 is the current version, 19041 is the previous one.
Staying on old versions of windows can also cause issues, its a no win situation. Newer versions fix bugs but can create new ones.

if its 19042.746 you on latest version so that isn't it...

does keyboard use its own software?

how did you optimize it after reset?
Who makes PC? is it brand name or custom? If custom, what make/model? - did you check website for model?
if custom, what motherboard? did you check motherboard website for drivers?

I don't know if input lag could be GPU drivers. Maybe try updating them as well.
 
Jan 20, 2021
18
0
10
0
ive updating my game ready drivers and put on gamemode and changed control panel settings to be more performance based( so nothing too much). I dont have keyboard software but before the factory reset it never cause problems so im doubting that it is the issue now. my motherboard is a b450 gaming( is that too vague?/). and the pc is custom built by my dad. it was working fine for over a year.
 

Colif

Win 10 Master
Moderator
MSI and Gigabyte both have a B450 gaming motherboards. which one is it?

are you running the AMD Ryzen Balanced or High Performance power plan?

maybe try another USB slot
have you tried another keyboard? or tried that one in dads pc since I assume he has one (he made yours after all) just to make sure its not kb.
 
Jan 20, 2021
18
0
10
0
how can i check which motherboard u have? also im running nvidia so i cant do Amd power plan. also what should i try for another USB Slot. I know i sound a bit clueless but im pretty useless with about pcs
 

Colif

Win 10 Master
Moderator
B450 is an AMD motherboard. The power plan is based on it, not your GPU.
right click start
choose power options
under Related Settings, click Additional power settings
in the next window, what power plan are you running?
 
Jan 20, 2021
18
0
10
0
Ok ive checked and the mother board is by gigabyte. what should i do next? when i tupe in power options in settings in comes up witht he windows settings which i already set to performance
 

Colif

Win 10 Master
Moderator
So no AMD power plans?


if you don't, perhaps you need to update some more drivers.

Is this the board? https://www.gigabyte.com/au/Motherboard/B450-Gaming-X-rev-1x/support#support-dl-utility
I can only see one Gigabyte gaming board. Did you install the Gigabyte App centre as I know it updates drivers (it can be tricky to use, it highlights all the apps which aren't really useful. or needed). I have a Gigabyte motherboard myself.

if you run it, the first screen just shows installed apps, you need to click the Live update button to get updates. (I have it highlighted in below photo, mouse cursor not shown in screenshot), then on next screen, click the orange tick above the rest of the individual ticks to deselect.


Its tricky as you need to scroll down as there is another section below for 3rd party software and you probably don't want it
You really only want drivers


I am currently up to date so can't show what drivers look like.

you might need to get chipset drivers from https://www.amd.com/en/support/chipsets/amd-socket-am4/b450 to get the AMD power plans, but Gigabyte App might update them for you.

also what should i try for another USB Slot
i mean plug KB into another USB slot.

I have to go but will look in here later. Its 4.30am here.
 
Last edited:

ASK THE COMMUNITY