Question Installed 3070 now Bios won't detect boot drive

Dec 2, 2020
2
0
10
0
I just finished installing my upgrade gpu 3070 and when I try to boot it just goes to BIOS and in BIOS it does not detect any boot drives. The main boot drive is showing in BIOS as a NVME available drive. My normal boot drive is an m.2 drive but I also have 2 ssd drives. If I plug in a usb boot drive it does detect that.

Motherboard: Asus Tuf Gaming x570 pro
CPU: Ryzen 5600x
GPU: MSI Gaming Trio RTX 3070
Boot Drive: XPG Gammix S50 Lite 2tb
Ram: 4 x 8gb Crucial Ballistix 3200mhz
Power Supply: Corsair 750x 2019

I have tried installing the m.2 drive in both slots and nothing has changed. Computer was able to boot and run just fine before graphics card was switched out. BIOS is up to date and drivers for the new gpu were preinstalled before I switched cards.
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

We're going to need a little more information. Make and model of your PSU and it's age? You might want to also see what BIOS version you're on for your motherboard and cross reference Asus's support site to see if you have any BIOS updates pending. Gradually work your way to the latest if you have a number of updates pending.
 
Dec 2, 2020
2
0
10
0
Welcome to the forums, newcomer!

We're going to need a little more information. Make and model of your PSU and it's age? You might want to also see what BIOS version you're on for your motherboard and cross reference Asus's support site to see if you have any BIOS updates pending. Gradually work your way to the latest if you have a number of updates pending.
Updated with further system specs, does not seem to be a BIOS or power supply issue as it will boot to windows off a thumb drive, and everything is detected. It will just not boot off the normal boot drive.
 

ASK THE COMMUNITY

TRENDING THREADS