Question Installed a new video card, after 2 weeks, computer powers up but now screens remain blank?

Jul 31, 2020
1
0
10
0
My parts list:

Gigabyte GA-X58A-UD3R

i7-950

Gigabyte HD 6870 (old video card)

AMD Windforce GV-R939 G1 8GD (new video card)

Power Supply: Corsair TX 850 (850 Watts)



My Problem:

(Noob question / semi-tech illiterate): I recently installed a AMD 8GB graphics card my friend gave me, it worked like a champ for 2 weeks (until I installed DCS World and started messing with the display settings).

Computer started acting wonky and now it refuses to turn on... (Note: before it died, a fan (or fans?) at startup would spool up and make a ton of noise, sounding like they're going on overdrive... not sure if it was the CPU or the new video card... but happened for like a week or two before it died sometimes)

Any idea what it can be?

I think it's related to the graphics card... but when I turn on the computer, nothing happens... it powers on and hums and all that, but the computer screens just stay blank.

My computer:

(was built in 2011, top of the line parts at the time, but really it still ran like a champ, would be a shame to have to drop $1k+ on a new top-of-the-line setup)

List anything you've done in attempt to diagnose or fix the problem.

So far I've:

  • Tried my other monitor, also tried using the HDMI cable instead of the other port

  • Swapping cable monitors to make sure cables weren't shot

  • Turning computer on and off multiple times

  • No onboard graphics card slots (so I can't try the onboard CPU graphics card)... and I can't find my old Gigabyte video card (fail)... so I can't plug in the old one to see if it works.

Pics of computer innards and components:

View: https://imgur.com/hK1gf54

View: https://imgur.com/5lf6om1

View: https://imgur.com/Fgynk2D




Additional Details:

  • All the lights inside the computer turn on, and the fans spin... maybe it's the power supply? The AMD graphics card requires 600W, and the TX850 is 850W... not sure if that would be the issue. It did run fine for a while before the computer died.
 

ASK THE COMMUNITY

TRENDING THREADS