Question Installed EVGA Supernova G3 650w but no monitor display.

Jun 16, 2019
10
0
10
0
I installed this new psu as I am looking to upgrade my gpu soon. However, with the g3 installed my case led lights turn on and the cpu and gpu fans spin, but the case fan does not move and there is no signal on my monitor and no power to my mouse and keyboard. Taking out the g3 and putting in my old 500w psu (some generic brand) allows me to boot with no issues.

This is the second g3 I have tried with the same results, I returned the first after calling evga.

My main question is, is there something I could be doing wrong to cause the issue or did I get another bad psu?
 
Jul 8, 2019
39
1
45
2
If your PSU is brand new from certain dealers, it might be defective as some lower priced items are at that price for a reason. And hey, I don't mean to be bad mouthing any companies out there.
 
Jul 8, 2019
7
2
15
0
Did you plug in 8 pin CPU power connector ? Usually something like that happens if u didn't. Also don't mix it up with PCIE/GPU 8 pin power connector, they look almost the same. It shouldn't fit in, but maybe you can get it in there with some force.
 
Jun 16, 2019
10
0
10
0
Did you plug in 8 pin CPU power connector ? Usually something like that happens if u didn't. Also don't mix it up with PCIE/GPU 8 pin power connector, they look almost the same. It shouldn't fit in, but maybe you can get it in there with some force.
I did plug in the cpu power connector, its two 4-pin connectors so I can try it again tomorrow and maybe use a bit more force. It'll only fit in one direction correct? Also, the cables are labeled so I know I'm using the right connectors.
 
Jul 8, 2019
7
2
15
0
I did plug in the cpu power connector, its two 4-pin connectors so I can try it again tomorrow and maybe use a bit more force. It'll only fit in one direction correct? Also, the cables are labeled so I know I'm using the right connectors.
No, don't use force. It should fit in, otherwise you're trying the wrong connector. If you have 8 pin socket on your board, you have to use both connectors. If you have 4 pin, only one should fit in - use one that fits. You should be able to figure out correct position by clips.
 

jonnyguru

Distinguished
I did plug in the cpu power connector, its two 4-pin connectors so I can try it again tomorrow and maybe use a bit more force. It'll only fit in one direction correct? Also, the cables are labeled so I know I'm using the right connectors.
And you're using the cables that came with the EVGA and not the ones from your old PSU, right?
 
Jun 16, 2019
10
0
10
0
No, don't use force. It should fit in, otherwise you're trying the wrong connector. If you have 8 pin socket on your board, you have to use both connectors. If you have 4 pin, only one should fit in - use one that fits. You should be able to figure out correct position by clips.
Yeah by force I meant just pushing it down a little more - I've been pretty gentle, I'm afraid of wrecking my motherboard. I'll make sure both are in and pay closer attention to the clips when I try tomorrow.
 
Jun 16, 2019
10
0
10
0
Just checking. You never said what the old one was. ;) And there's no adapters or anything either (like Molex to SATA)?

What make/model motherboard is this? I have a hunch.
Yeah sorry if that came off bad haha. There's no adapters and the mobo is an ASRock h110m-ds/hyper.
 

jonnyguru

Distinguished
Ok..

Put the EVGA in, clear the CMOS. Try again.

If that doesn't work, put the old PSU back in, flash the BIOS to the newest version. Swap out to the EVGA. Try again.

For some reason I keep seeing this issue with EVGA PSUs and certain boards where the PS Good timing doesn't sync up and the mobo refuses to POST. Hopefully it's just that.
 
Jun 16, 2019
10
0
10
0
Ok..

Put the EVGA in, clear the CMOS. Try again.

If that doesn't work, put the old PSU back in, flash the BIOS to the newest version. Swap out to the EVGA. Try again.

For some reason I keep seeing this issue with EVGA PSUs and certain boards where the PS Good timing doesn't sync up and the mobo refuses to POST. Hopefully it's just that.
Ok I'll give that a shot, thanks for all the help!
 

ASK THE COMMUNITY

TRENDING THREADS