[SOLVED] Installed new components - now PC does not even POST ?

LeoLoon

Reputable
May 29, 2017
28
0
4,530
0
I've just ordered new components to upgrade my old stock PC and they arrived just yesterday. Had everything setup, tried turning it on, but it doesn't boot at all. Although, fans, cooler, and lights are all running.

I dug through some older motherboards and found an internal speaker. Plugged it in but it did not produce any beep sounds (I tested it on a different unit and the speaker does work).

I'm planning on getting to a shop and hopefully troubleshoot the issue. However, do you guys have any suggestions on what can I attempt to fix it before I get a professional to do it?

MOBO: Gigabyte B450M D3VH V2 (New)
CPU: Ryzen 7 5700g + Wraith Stealth Cooler (New)
GPU: iGPU
RAM: 2 x 16gb Corsair RGB Pro (New)
PSU: CoolerMaster MWE White 650 230v
SSD: Kingston 256gb SSD

I can't take a screenshot of the unit right now but I'm pretty certain that everything is plugged in properly. I used the same monitor that I use as my secondary display for my laptop so I'm certain that the it is not the issue.

The PSU and SSD are from the previous build which was having issues, partly why I bought new parts.

Things I've already tried:
  • Reseat everything
  • Switching RAM slots
  • Reinsert CMOS
Edit:
I also have this weird issue where shorting the power switch pins and holding the power button doesn't trigger a force shutdown but instead, the LED on motherboard just keeps blinking.
 
Last edited:

LeoLoon

Reputable
May 29, 2017
28
0
4,530
0
as it being B450 chipset released year ago, then you will need to put inside compatible CPU first (ryzen 2000/3000), so you can update BIOS to support ryzen 5000G serie
there is no workaround for that
Oh, the label on the box makes sense now. I thought it would just work out of the box since its specified that it supports the 5000 series in their website.

I only have a couple of A8-6600 laying around. I'm screwed. Just gonna have to rely on the store then.
 
Nov 27, 2021
2
0
10
0
as it being B450 chipset released year ago, then you will need to put inside compatible CPU first (ryzen 2000/3000), so you can update BIOS to support ryzen 5000G serie
there is no workaround for that
Does this apply to the B550 motherboards as well do you know? Having a similar issue.
 

ASK THE COMMUNITY