Question Installed new CPU and pc restarts when playing certain games

Nov 30, 2022
4
0
10
0
Hello all, this is my first time posting on something like this but I’m really confused on what to do now.

I recently upgraded my CPU from a Ryzen 5 3600x to Ryzen 9 5900x and bought a Deepcool Assassin 3 to go with it. Install wasn’t a problem and computer ran fine till I tried to play Call of Duty MW2 and it would instantly restart the PC before the actual game launched. I also played Warhammer 40k Darktide but it’ll only play for about 30mins before doing the same thing. Before on my old CPU I didn’t have any of these problems. I’ve now tried reinstalling the old CPU and now I keep getting an orange light on the motherboard. I’ve been able to get to my Bios before and configure it but when it restarts it shows no picture. I’ve tried resetting the CMOS a handful of times and sometimes it works. I’ve also downloaded the BIOS required for new CPU.
Any help will be extremely appreciated

My CPU temps on the Ryzen 9 were around 70c when playing

Edit: Finally got my old CPU to work again and games run fine like before.

Any help will be extremely appreciated

Specs:
ROG Strix B-550 Motherboard
Ryzen 5 3600x/Ryzen 9 5900x
32gb DDR4 ram
RTX 3080
GT 650 Watt
 
Last edited:

kanewolf

Titan
Moderator
Hello all, this is my first time posting on something like this but I’m really confused on what to do now.

I recently upgraded my CPU from a Ryzen 5 3600x to Ryzen 9 5900x and bought a Deepcool Assassin 3 to go with it. Install wasn’t a problem and computer ran fine till I tried to play Call of Duty MW2 and it would instantly restart the PC before the actual game launched. I also played Warhammer 40k Darktide but it’ll only play for about 30mins before doing the same thing. Before on my old CPU I didn’t have any of these problems. I’ve now tried reinstalling the old CPU and now I keep getting an orange light on the motherboard. I’ve been able to get to my Bios before and configure it but when it restarts it shows no picture. I’ve tried resetting the CMOS a handful of times and sometimes it works. I’ve also downloaded the BIOS required for new CPU.
Any help will be extremely appreciated

My CPU temps on the Ryzen 9 were around 70c when playing

Any help will be extremely appreciated

Specs:
ROG Strix B-550 Motherboard
Ryzen 5 3600x/Ryzen 9 5900x
32gb DDR4 ram
RTX 3080
GT 650 Watt
A 5900 CPU plus a 3080GPU on a 650W power supply is probably your problem....
 
Nov 30, 2022
4
0
10
0
So I got the new psu but unfortunately it didn’t seem to be the issue and still restarts when I try launching CoD. I’m going to assume something in my build isn’t compatible with the new CPU and or something wrong with the CPU itself.
Also I noticed now a red light appears on the MB and it didn’t before. I’m aware it means something hardware wise is wrong which is probably the CPU.
 
Last edited:

ASK THE COMMUNITY