Question Installed new CPU, freezes on startup

cheesebot

Honorable
Aug 7, 2014
6
0
10,510
0
I just installed a new CPU (i9-9900K) and when on the loading windows loading screen it freezes, it is now to the point of automatic repair which is also freezing. I have an MSI Z390 motherboard so I know that everything is compatible, but I can't figure out why its freezing. I haven't changed anything in the BIOS and I can launch into the BIOS and it registers the CPU as working. Any suggestions or help?
 

rickypicky5

Upstanding
Sep 9, 2019
315
34
240
14
Is there a way for me to update the BiOS without being able to get into windows?
CPU temp is 40 degrees Celsius in BiOS.
PSU is a Corsair RM 750X 80+ Gold
Getting into BIOS is not dependent on getting into Windows.

Press the power button on your PC and start hitting the "delete" key repeatedly. At least on my Gigabyte Z390 motherboard it's the delete key, it may be a different key on your motherboard. With luck, the BIOS screen will display on your monitor after a few seconds.

Once into the BIOS, check to see what BIOS version you have. If you don't have the latest non-beta BIOS, I strongly suggest you download it and install it. It's likely that if you purchased your i9 9900k in the last few months it has a 'stepping' that may not be compatible with the earlier versions of BIOS.
 
Last edited:

cheesebot

Honorable
Aug 7, 2014
6
0
10,510
0
Press the power button on your PC and start hitting the "delete" key repeatedly. At least on my Gigabyte Z390 motherboard it's the delete key, it may be a different key on your motherboard. With luck, the BIOS screen will display on your monitor.

Once into the BIOS, check to see what BIOS version you have. If you don't have the latest non-beta BIOS, I strongly suggest you download it and install it. It's likely that if you purchased your i9 9900k in the last few months it has a 'stepping' that may not be compatible with the earlier versions of BIOS.
Okay, I just installed the latest BiOS after putting the old CPU back in, everything is still running fine so I am going to try to reinstall the i9-9900k again.
 

ASK THE COMMUNITY

TRENDING THREADS