Installed new CPU, Mobo and Ram and my psu cpu connector doesn't work

oliverschurmann

Prominent
Oct 27, 2017
19
0
510
0
Like it says in the title, I installed a new cpu, mobo and ram but doesn't boot with my power supply connected to cpu power connector. my psu works as I tested it on old motherboard.

any suggestions would help
 

Bob125484

Reputable
Jun 13, 2015
627
0
5,360
129


List your CPU, mobo and RAM to see if they are compatible
 

oliverschurmann

Prominent
Oct 27, 2017
19
0
510
0


g4560
Biostar h110mhc
1x8gb ddr4 samsung ram
Palit gtx 1050ti
gigabyte superb 550p psu
 

Bob125484

Reputable
Jun 13, 2015
627
0
5,360
129


G4560 is Kaby Lake so it is 7th gen CPU
h110mhc support both 6th gen Skylake and 7th gen Kaby Lake CPU. However, h110mhc mobo most likely needs 6th gen CPU to update bios in order for mobo to work with 7th gen CPU. I went to MSI website and look at CPU support for your mobo and I do not see it on the support CPU list. Will it work after bios update??? Answer is I don't know since it is not on CPU support list and I do not know why it is not there. Here is MSI link for your mobo
http://www.biostar-usa.com/app/en-us/mb/introduction.php?S_ID=877#cpusupport
 

oliverschurmann

Prominent
Oct 27, 2017
19
0
510
0


I have updated the bios and my PC runs but I'm using a 210w PSU from an old Asus machine so I have my parts out of my case sitting on my mobo box. The pc works fine but I can't put it in the case as the 210w PSU is meant from sff case so it's the wrong size and the cables are too short.
 

Bob125484

Reputable
Jun 13, 2015
627
0
5,360
129
Great, at least it works for you now. I guess you just have to buy a new case and new power supply to solve your problem. I think your mobo is micro-ATX so you need case support at least micro-ATX and standard power supplies. Don't use that 210W PS since it is not safe to power your G4560/1050Ti. You could damage your CPU, mobo and GPU.

 

oliverschurmann

Prominent
Oct 27, 2017
19
0
510
0


Well I know my parts work is just that I have an atx case that fits it all just that i have to use the 210w for now until I can fix my gigabyte 550w PSU (the one with the CPU connector problem) and have it out of the case. But it's confusing as the 550w the one with the CPU problem works fine with my old Mobo and CPU.
 

Bob125484

Reputable
Jun 13, 2015
627
0
5,360
129


Based on your parts swapping and testing, all Your hardware are definitely working. I think double check your connection on 550W on new mobo/CPU.

 

ASK THE COMMUNITY