Question Installed new PSU and the system won't boot. Any ideas?

Aug 10, 2019
4
0
10
0
UPD Wу booted the system, but now the CPU fan isn't working. At first it tried to spin, but now it's kinds not spinning (( Would be grateful for ideas.

The current system specs:

Motherboard is ASUSTeK P9X79
CPU is Intel (К) Core(TM) i7-4820K 3.70GHz
RAM 4 lines DDR 3 by 4 GB
Video ASUS nVidia GeForce GTX 760 with 2Gb
PSU is Thermaltake 750W Toughpower Gold
DirectX11
Windows 8.1

I've encountered the problem when my PC would re-start on its own. First it only happened with some intense GPU load on (like playing games) and just in three weeks it went in the state, when it booted and could be on (even playing games and all) for days or just restarting loop. At first we decided it's my GPU failing, but nope. CPU temperatures are not high also. So we talked to the tech guy in the local store and he suggested it's the PSU.

So I ordered a new PSU - Thermaltake ToughtPower Grand RGB 750W 80+ Gold. The only difference berween them is that one is semi-modular and 5 yrs old, the other one is modular.

My hubby installed it into the case and now we are having problems: with new PSU in the motherboard has a green led light on, but fans, CPU and GPU not running. We tried both 8pin and 4pin without success. We re-checked that all cords are tight-in, and still no luck. If we plug in the old PSU - system is working.

We just lost at what's wrong, why there's no supply to the CPU, GPU and fans? How can I test is the PSU is in working condition? I've read lots of topics here, but still don't understand what to do. Any ideas?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS

Latest posts