[SOLVED] Installed new Ram, PC wont boot up.

Brendan_42

Reputable
Jul 24, 2017
14
1
4,515
0
I installed some new ram as the title implies. I previously had 3 ram sticks in, one 8gb and 2 4gb. I removed those and plugged in the new ram, 2 8gb sticks. The new ram should clock at a higher frequency of 3600mhz compared to the old ram that ran at 2133.

I plugged in the 2 new sticks and my pc booted up properly but the speed was still set to 2133 according to my Task Manager. So I went into my BIOS and set my target frequency to 3600mhz and then saved and restarted my PC and now it wont boot. any suggestions?

For context, I have an ASUS X570-P mother board that has ram frequency support up to 4400mhz.
 
unfortunately, im pressed for time and have to leave for work now. ill get back to this tomorrow most likely. but i apologize for the inconvenience. the timing for this problem to occur has just been poor
No worries. Your issue is Ryzen doesn’t like odd timings. Try 3600mhz, you’ll need to manually set the timings to 18-20-20-40 and it should work fine.
 
I installed some new ram as the title implies. I previously had 3 ram sticks in, one 8gb and 2 4gb. I removed those and plugged in the new ram, 2 8gb sticks. The new ram should clock at a higher frequency of 3600mhz compared to the old ram that ran at 2133.

I plugged in the 2 new sticks and my pc booted up properly but the speed was still set to 2133 according to my Task Manager. So I went into my BIOS and set my target frequency to 3600mhz and then saved and restarted my PC and now it wont boot. any suggestions?

For context, I have an ASUS X570-P mother board that has ram frequency support up to 4400mhz.
What are your RAM timings? Reset your CMOS first and it should boot.
 

Brendan_42

Reputable
Jul 24, 2017
14
1
4,515
0
What are your RAM timings? Reset your CMOS first and it should boot.
I would do that but it literally is only turning on and then does nothing. my monitors dont light up, keyboard doesnt light up, mouse doesnt light up. My tower has become an expensive night light.
 
I would do that but it literally is only turning on and then does nothing. my monitors dont light up, keyboard doesnt light up, mouse doesnt light up. My tower has become an expensive night light.
You have to remove the CMOS battery on your motherboard.

did your computer just “fail to boot” or was it restarting a bunch of times and you just turned it off?
 

Brendan_42

Reputable
Jul 24, 2017
14
1
4,515
0
You have to remove the CMOS battery on your motherboard.

did your computer just “fail to boot” or was it restarting a bunch of times and you just turned it off?
I hit the power button and then the fans start up and just run. ive been letting it run a little bit to see if anything changes but no, its just sitting here running but nothing else is happening, not even restarting over and over.
 
I hit the power button and then the fans start up and just run. ive been letting it run a little bit to see if anything changes but no, its just sitting here running but nothing else is happening, not even restarting over and over.

Until you clear your CMOS it’s never going to boot.
 

Brendan_42

Reputable
Jul 24, 2017
14
1
4,515
0
When you bought the RAM, there were advertised timings. The packaging had timings. The sticks themselves most likely have the timings on them. We need the 3600 timings, not the 2133 timings it’s currently running at
according to the website, the tested latency is 18-19-19-39
 
unfortunately, im pressed for time and have to leave for work now. ill get back to this tomorrow most likely. but i apologize for the inconvenience. the timing for this problem to occur has just been poor
No worries. Your issue is Ryzen doesn’t like odd timings. Try 3600mhz, you’ll need to manually set the timings to 18-20-20-40 and it should work fine.
 

Brendan_42

Reputable
Jul 24, 2017
14
1
4,515
0
No worries. Your issue is Ryzen doesn’t like odd timings. Try 3600mhz, you’ll need to manually set the timings to 18-20-20-40 and it should work fine.
I did it! Went into the bios and enabled the Asus DOCP settings and it automatically adjusted my clock speeds for me. RAM Frequency is now at 3600mhz, thanks for your help yesterday!
 
Reactions: bmockeg

ASK THE COMMUNITY