Jul 6, 2022
Hi there,
i recently upgraded my PC ram from 8GB to 16GB by adding another 8GB stick, using the same Ram module from the same buyer.
and changed my Mobo from ASROCK N68-VS3 to GA-970A-DS3P.

i made those changes without reinstalling windows, the PC started normally all working good, i made all recommended updates from windows and from Driver Booster 9.

all working good but the ram it's reads, 8GB instead of 16GB, the ram is 1866Mhz and i don't think it's read at it full speed.

i'd love to read professional users opinion on this small issue.
i mainly use my computer for school - i'm happy with it as it it is in case we didn't manage to a find solution for this small issue

thanks in advance

1/System infos :
OS: Windows 11 Enterprise
MOBO: GA-970A-DS3P REV 2.1
CPU: AMD FX(tm)-8300 Eight-Core Processor 3.30 GHz
RAM: 2 * 8GB DDR3 1866MHz (Red Fury HyperX)
512GB HDD and 512GB SSD

2/Useful ScreenShot :
[1]System > About :
[2]BOOT Advance Options :
[3]CPU-Z General Infos :
[4]BIOS :
[4]RAM on MOBO :
Ps:i have changed the Rams places in the Mobo Still didn't work.

3/Notes :
*System about > Installed Ram Showing : 16.0 GB (7.96 GB usable)
*CPU-Z > Memory tab Showing Ram in Single Channel and in SPD tab Showing 889MHz Speed while it is 1866MHz
Jul 6, 2022
No sir, it's just the ram heatsink, that is applied in reverse, both sticks are inserted properly.
i can see both rams in CPU-Z and in system about.
i just can't manage to make both Rams work. Installed RAM 16.0 GB (7.96 GB usable)
Jul 6, 2022
understood, is there a way to check if the system is neglecting the ram due to an issue in the hardwire or the hardwire is good and it's just disabled and can be enabled somehow (maybe reinstalling windows for example)?
it does shows 16GB...do a quick test
run memtest just to see how much ram it shows
doesnt have to be run for too long, just to see how much ram it runs on
  • Like
Reactions: imogen99
Jun 27, 2022
The first thing you need to determine is if the motherboard is in fact reading all four of the memory modules inserted into the memory slots of the motherboard.

You can do this by looking at screen when the system is first powered on to see if the memory count is displayed by the bios.

Or by entering the bios where it will report the full amount of memory read.

If the bios reads all 16Gb or ram.

You must then check what version of windows you are running, the version must be a 64 bit version of windows os installed.

When you look at the system information option of windows it will report the physical amount of ram seen by windows.
And should be 16Gb.

If you find that 16Gb is not reported as the total physical memory fitted.
But the bios reports 16Gb of memory detected.

It means that the configuration of windows has been capped to see, or use only a set amount of physical memory in it`s configuration settings.

To check if the memory windows uses is capped.

Click on start.
In the search bar type : MSCONFIG.
Press enter.

A new window will open.

Click on the boot tab at the top of the new window.
Then click on the Advanced option tab.

A new window will open.
To the top left you will see a tick box for maximum memory.
If there is a value typed into the box bellow it remove all of the numbers.

Then un tick the maximum memory box if it is ticked.

Click ok
Then click apply.
Then ok again.

Restart the system.
Let windows load.

And again open up windows system information.

If it says Installed physical memory fitted as 16Gb.

Problem solved.
  • Like
Reactions: imogen99
Jul 6, 2022
guys - can bad PSU cause to ram not read ?
i have tested the rams on other pc and it worked find // i ordered another ram from different seller still wont boot.

seems like this pc don't accept any ram except the one came with it.