[SOLVED] Installing additional Ram problems.

Sep 3, 2022
2
0
10
0
Hello, I decided to upgrade my current ram (two sticks, 16gb of ram) so I could have 32 gbs of ram with 4 total sticks. When I boot my pc with the new sticks of ram (same as the ones I had originally bought) everything turns on inside the case... rgb and fans. My mouse and keyboard however never turn on, as well as my monitor never gets a response. When I take out the new ram, everything works fine again. I've gone to google, but I can't figure anything out.

My current pc:
B450 A max pro
Corsair Vengeance RGB Pro 16 GB (2x8 GB) DDR4-3200 Cl16 Memory
AMD Ryzen 5 3600x
 
Last edited:

Karadjgne

Titan
Ambassador
Zen capped out at 2133MHz/2400MHz with 4x sticks. Zen+ raised that to 2666MHz. Zen2, which is the 3000 series cpus, raised that to 2933MHz. With very few systems, and using ram OEM Samsung B-die, it was possible, sometimes, to get 3200MHz on all 4 sticks and be stable, but that generally took not only the latest Agesa bios, but also some timings tweaks.

Turn off XMP with 2 sticks. Reboot so it will run default settings for ram. Then turn on XMP again but manually change the speed to 2933MHz.
 
Reactions: CountMike

Karadjgne

Titan
Ambassador
Zen capped out at 2133MHz/2400MHz with 4x sticks. Zen+ raised that to 2666MHz. Zen2, which is the 3000 series cpus, raised that to 2933MHz. With very few systems, and using ram OEM Samsung B-die, it was possible, sometimes, to get 3200MHz on all 4 sticks and be stable, but that generally took not only the latest Agesa bios, but also some timings tweaks.

Turn off XMP with 2 sticks. Reboot so it will run default settings for ram. Then turn on XMP again but manually change the speed to 2933MHz.
 
Reactions: CountMike

ASK THE COMMUNITY