Installing Windows 7 on X470 AORUS mobo and Kingston SSD

Jan 11, 2019
3
0
10
0
Problem
- Win 7 doesn't see SSD OR
- Win 7 installer error "a required cd dvd drive device driver is missing", but SSD is show in diskpart

Variables
- no DVD drive
- no USB 2.0 port
- initial installation succeeded with same ISO and BIOS settings, but the second install fails with the above

Details
I've recently bought a PC with a Gigabyte X470 AORUS Ultra Gaming motherboard and a combo of Kingston A1000 SSD + HDD. The PC came with Ubuntu and it had a GPT partition on the SSD and some other partitions on the HDD. I've injected the installation ISO with the following USB drivers to get to use my keyboard and mouse during the install:

amdhub30.inf
amdxhc.inf
amdhub3.inf
amdxhc.inf
amdhub31.inf
amdxhc31.inf

And this storage driver from Intel
IaNVMe.inf

These drivers are from Gigabyte's WindowsImageTool, but I've injected them manually with DISM because using the utility gave errors of "failed to add drivers to offline image" or just didn't work during the installation. Also, when possible I kept only the 64 bit version of the drivers. The reason for the above selection was that including other drivers gave me DISM errors, which in turn made for a not usable USB installation. I've added them to both install.wim and boot.wim

With the ISO boosted with those drivers I installed Win 7, but managed to get it infected with adware while I was batch downloading various programs to actually set it up. Since it was a fresh install, I figured it would be better to just reinstall it than trying to disinfect it. But now, the installer only sees the HDD, even though before it was able to see the SSD just fine! Also in diskpart it doesn't see it. I've been reading all about it and trying various things, the ones that come to mind are:
- installing Ubuntu with GPT to recreate the initial conditions
- using Gparted to clean the SSD or format it as NTFS
- installing Ubuntu with MBR
- various other driver and BIOS settings combinations

Nothing worked, but as I kept reading, I've hit upon a post which mentioned NVM hotfixes for Windows 7 in the following KBs:
https://support.microsoft.com/en-gb/help/2990941/update-to-add-native-driver-support-in-nvm-express-in-windows-7-and-wi
+ KB3087873

I added these packages in my ISO image and this time I get the "a required cd/dvd drive device driver is missing" error, but the installer can see the SSD in diskpart. However, I cannot continue past the error, even though I've tried everything that worked for some people:
- unplugging the USB and starting the installer again
- plugging the USB to a different port when receiving the error and starting the installer again
- unplugging the USB with the error and plugging the original one before continuing. This gets rid of the error but then my SSD again is not seen!
- having 2 USBs with Win7 images plugged
- adding a stick with AMD preinstall drivers and loads of other drivers for all possible architectures and browsing to it in case it would pick the driver up from there (it did not)

I've also tried creating the ISO image in other ways, with Asrock's Win7USBPatcher and with NTLite. I'm at my wits end, tried all these solutions that worked for others but not only they do not work, I don't understand why the installer was able to pick up the SSD with no problems before, and now it doesn't!

Looking for a helpful nudge here, I've been spending days on this and it would be great to actually start using the PC for something other than trying USB sticks and rebooting :ouch:
 
Jan 11, 2019
3
0
10
0
Yes, Win 7 works, it just needs more effort. I eventually installed it on the HDD, then cloned it on SSD with Easeus To-Do Backup. So far, so good.
 

ASK THE COMMUNITY

TRENDING THREADS