Question Intel 660p 2TB - Dell 7490 - low 4k score

rumcajs997

Prominent
Aug 2, 2017
3
0
510
0
Hi,

I just installed Intel 660p 2TB in Dell 7490 and 4k score is way below what I have seen in all reviews.

View: https://imgur.com/a/XcUzbvg

View: https://imgur.com/a/oivNLyY

View: https://imgur.com/a/XhN1cqp



According to reviews, I should get easly 50-60MB/s / 130-140MB/s - http://www.thessdreview.com/featured/intel-ssd-660p-m-2-nvme-ssd-review-1tb/3/

Laptop is set in BIOS at Raid On (instead of AHCI), the system is fresh, the drive is empty. I do tests on battery but I set Power Management to the highest setting, so I doubt that it is the reason.

Is it possible that laptops have to much slower speeds? Because I believe that all online tests were undertaken on PCs.

I found some NVMe driver at Intel's webpage but this driver doesn`t see the disk at all even though 660p 2TB is on the support list.

Thanks in advance for some advice.
 
Last edited:

rumcajs997

Prominent
Aug 2, 2017
3
0
510
0
I have changed Raid On to AHCI in BIOS and installed fresh Windows 10 again. The same story. But since I have come across some topics where people said that they have got perfectly fine speeds in Safe Mode but half 4k in Normal Mode, I tried myself and it seems that in Safe Mode, the drive has got full speed:

Crystal Disk Mark in Windows Safe Mode:

Sequential Read (Q= 32,T= 1) : 1981.152 MB/s
Sequential Write (Q= 32,T= 1) : 1910.724 MB/s
Random Read 4KiB (Q= 8,T= 8) : 973.402 MB/s [ 237647.0 IOPS]
Random Write 4KiB (Q= 8,T= 8) : 953.787 MB/s [ 232858.2 IOPS]
Random Read 4KiB (Q= 32,T= 1) : 286.274 MB/s [ 69891.1 IOPS]
Random Write 4KiB (Q= 32,T= 1) : 260.536 MB/s [ 63607.4 IOPS]
Random Read 4KiB (Q= 1,T= 1) : 55.741 MB/s [ 13608.6 IOPS]
Random Write 4KiB (Q= 1,T= 1) : 136.854 MB/s [ 33411.6 IOPS]


Test : 1024 MiB [D: 0.0% (0.2/781.2 GiB)] (x4) [Interval=5 sec]

As you can see its spot on as per reviews. I checked AS SSD as well and is faster then in Normal Mode, its still off when comparing to reviews (it has still got less than 100MB/s 4k Write).

But going back to Normal Mode and 4k is again half speed...

https://answers.microsoft.com/en-us/windows/forum/all/ssd-speed-halved-when-running-outside-of-safe-mode/4f42834a-0af0-482a-936c-964e49e8c73d - this guy, has got exactly the same problem with Intel drive, but with Samsung it works fine.

I have managed to install Intel NVME driver from Intel`s site but the score is even worse...

I am starting to regret this drive, there was Micron 1100 512GB SATA m2 installed in my laptop out of the box, and it had better 4k than this Intel NVMe.
 

Similar threads


ASK THE COMMUNITY