Question Intel 660p SSD broke; now only shows up after restart of computer

Jun 16, 2019
1
0
10
0
I got a Intel 660p SSD a few months ago and it was running without any problems until I stupidly filled up the whole 1TB of the SSD with downloads and the computer crashed. After the crash the SSD can't be detected anymore. The systems (i tried it in both windows and a hackintosh) arent even detecting the SSD. So it's not about broken partitions, but the SSD controller itself doesn't get recognized.

Here is the strange thing: If I power on the computers for the first time the SSD is always not getting detected. But If I restart the computerit appears. It only works if I automatic restart the computer (inside windows or mac) and not if I turn the computer off and on again.

With this method the SSD is working normally and there seem to be no errors. I run a few tests. And I also deleted 200GB to make sure this wasnt the reason.

Another strange thing: If I send the computers sleeping after they found the SSD and I wake them up, the computers hang up. Proably because they cant find the SSD again anymore. This is of course extremly frustrating as after each computer sleep I have to restart the computer twice to get the SSD.

I tried this on two computers and it's the only way the SSD appears. I have the right motherboard settings and the motherboard supports NVME. I rechecked that everything is set correctly. The SSD was always working before the crash.

My guess: Something of the startup of the SSD is broken or something power related (so the SSD only gets the power in the right moment when the computer restarts). Maybe a burned fused?

Any ideas?
 

ASK THE COMMUNITY

TRENDING THREADS