Question Intel 750 1.2tb NVMe drive no longer working...

nostrocrompt

Reputable
Aug 27, 2015
11
0
4,510
0
I'm afraid its toast. In the past month or so, my computer stopped accessing it altogether, no warning LED, nothing showing up in Disk Management.
In the Device Manager, I can see the NVM Express Controller device it is associated with, where it notes "This device cannot start. (Code 10) An I/O adapter hardware error has occurred."
Is there any other troubleshooting I can do or should I reach out to Intel at this point? I'm worried I paid a hefty price for being an early adopter of what I thought would be a better long-term storage solution 😨

I've ruled out that it's an issue with the slot, as swapping PCI slots had no effect. It also is not registering as a drive in BIOS. My boot drive is an Intel 750 400gb NVMe drive which is working with no issues, and has been since I built this thing almost 4 years ago.
 

nostrocrompt

Reputable
Aug 27, 2015
11
0
4,510
0
Thank you. I contacted Intel but have hit a snag in the RMA process. While I was able to provide a proof of purchase, the ISN/ Warranty sticker was removed from the drive, and I no longer have the box. Because the drive is unreadable by my computer, I have no way of recovering the full ISN - there is a QR code embedded on the PCB on one side that appears to provide all of the ISN except for the last two characters, but Intel is claiming that that is insufficient to determine that the product is still under warranty. I pointed out to them that the FTC has stated that "Warranty Void if Removed" stickers are not in fact legally enforceable, but I'm at an impasse as far as how to acquire the full ISN. Is there any other trick I haven't thought of or am I SOL?
 

ASK THE COMMUNITY

TRENDING THREADS