Question intel core i7 10700 is overheating?

Dec 1, 2022
5
0
10
0
Greetings,

I have a question regarding my CPU which i think is overheating, i have i7 10700 and AIO pump cooling with thermaltake liquid cooler.
While idle and doing nothing i get 30 - 40C temperature and while in steam and playing games like Call of duty modern warfare 2 (2022) & Warhammer 40.000 Darktide i get 90-99C.
Also i have Asus Prime Z490-A motherboard and while in these games motherboard turns on CPU led indicator to RED.
I have cleaned PC case and everything but still get these kind of temperatures.
Is it normal or should i worry?
Thanks in advance.
 

Eximo

Titan
Ambassador
That is a little small for an i7. Though I wouldn't expect throttling, might be on the way out. Either way it can be outdone by a high end air cooler which has far less things to go wrong.

Need to know the chassis details and motherboard and ram to make proper cooler recommendations.
 
Dec 1, 2022
5
0
10
0
I have build this PC 1 year ago and had no problems till now.
I have GTX 1660 and 16 GB of DDR4 RAM Kingston Fury Beast 2666 MHz
 

Eximo

Titan
Ambassador
If it is that new, then it may just need to have thermal compound re-applied. Since it does cool down to idle temps the pump is likely working. Depending on the motherboard settings, you might be overdoing the voltage to the CPU, something to look into.

Motherboard is slightly important, but not as much as knowing how tall the memory is. Beast is pretty small, so you should be fine with most air coolers if you go down that route.

Thermalright Peerless Assassin is tough to beat right now:

https://www.amazon.com/dp/B09SD44SL1?tag=pcpapi-20&linkCode=ogi&th=1

About double the surface area of your typical 120mm radiator (and half the cost)
 
Dec 1, 2022
5
0
10
0
I have re-applied thermal paste today, i thought that was the case, i have Asus Prime Z490-A motherboard, i have set default settings from BIOS but nothing helps.
 
Dec 1, 2022
5
0
10
0
While in-game CPU is working at 100° C and CPU-Z showing core voltage from 0.800 - 1.200, i just checked it for 5 minutes not to stress the CPU much.
 
Last edited:
Dec 16, 2022
1
0
10
0
Having the exact same issue. Same motherboard and everything. Will probably take it in to have it repasted and a new AIO put in. I can't figure out why it went from absolutely fine to molten lava overnight. It happened once before and a good cleaning fixed it but everything I've done today actually made it worse.

Update - it was the thermal paste. I did it myself and instantly went back to idling at ~32 and running games at ~40
 
Last edited:

ASK THE COMMUNITY