Question Intel D5400XS "Skulltrail" memory issue

I have a hobby build with the following specs:

MB: Intel D5400XS
CPU1: QX9775
CPU 2: QX9775
GPU: Zotac GTX 1080 Amp!
SSD: Samsung 860 Evo 256 GB (Windows 11)
HDD1: Western Digital Black 6 TB WD6003FZBX (RAID 0 - Games)
HDD2: Western Digital Black 6 TB WD6003FZBX (RAID 0 - Games)
NVMe: HP EX950 1 TB (Games / Pagefile)
PSU: EVGA SuperNOVA 1200 P3

So basically, I am experiencing an issue with the FB-DIMMs. Everything else works fine, but the motherboard for whatever reason only sees 16 GB. 2 of the 8 GB DIMMs will not post on the machine, and I have the latest BIOS update (2009). If I leave the DIMMs in the machine, CPU-Z shows all 4 DIMMs in Windows, but Windows only sees 16 GB and the MB only sees 16 GB.

So my question is thus: Do you think the sticks are bad? Do you think it could be a setting in the machine? I could hunt for 2 more DIMMs to find out, but I was curious what community thoughts are.

I tried the 2 "non-working" DIMMs in all 4 slots and I have tried the DIMMs at 667-800 MHz speeds. I re-installed the latest BIOS to rule out any issues and have booted in the failback BIOS to see if the DIMMs would populate. I also tested 2 of the working 8 GB DIMMs with 2 working 4 GB DIMMs and it posted with all 4 DIMMs with 24 GB of memory.
Last edited: