Question Intel Desktop Board booting but stuck on splash screen ?

Frostyy3001

Prominent
Nov 27, 2019
92
2
565
6
Hello! A friend of mine has given me his old Intel motherboard with his old CPU, And after setting everything up and adding my own graphics card, I powered it up, And it would post, but it would hang on the splash screen, on the EZ Debug LEDs the ROM and GPU LEDs would flash. And it would occasionally beep once. After removing the GPU and booting off onboard graphics the system would boot up fine! Its only with the GPU that it would hang on the splash screen! I have tried resetting the BIOS, but that didn't work. I do have an older card to try but cant find it at the moment. And I would've tried updating BIOS but I am too scared to after what happened with one of my old motherboards (I bricked it).

Specs:
Mobo: Intel Desktop Board E210882
CPU: Core i7 3770k Quad Core CPU @ 3.5GHz
RAM: 8GB (2x4GB) Dual Channel Memory
GPU: MSI GeForce GT 710 2GB

The older GPU that I want to try is an GT 520 1GB but like I said, I can't find it at the moment. Any help is appreciated!

UPDATE: I just entered the BIOS to change drive boot order, and when entering the BIOS it would say "CMOS Checksum Error" before entering the BIOS.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS