Discussion Intel Display Audio HDMI issue

Nov 12, 2018
6
0
10
0
Hi,

I am the owner of a Zotac MI547. I have an issue with HDMI audio in that some of my apps experience a directsound initialization error. It seems that an output sound device can't be found hence the issue.

The 2016 Intel HD Graphics 620 supplied with the PC works fine regardless of what the HDMI cable is connected to.

Upgrading the Intel graphics driver to 2019 causes a directsound error when launching MAME. The sound works fine throughout windows and in other applications however if I plug some headphones into the headphone jack AND set the default output sound device to HDMI audio, the sound in MAME works fine.

The PC is connected to a Samsung MiniOne dock via a HDMI cable - the error occurs with this setup. If I connect the MiniPC to the HDMI port on a PC monitor, this works fine.

I've also tried connecting the HDMI cable to my Sony A/V receiver which throws up the same error.

It seems although the HDMI cable is connected and sound in windows works fine, when launching MAME, it thinks there are no audio output devices available.

In summary the 2 workarounds are:

1. Use 2016 intel graphics driver.

2. Use 2019 intel graphics driver and plug headphones into headphone jack but set default output sound device to HDMI audio.

The realtek audio manager doesn't give me an option to disable headphone jack detection - perhaps that may resolve the issue however it's important to note that the error doesn't occur with the 2016 intel graphics driver.

Any suggestions would be appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS