[SOLVED] Intel I7-10700KF: low CPU usage but high frequency ?

TheFlyingCelt

Honorable
Jul 28, 2015
45
1
10,545
2
Hi everyone,

I recently built my new computer with a

MSI Z490-A PRO motherboard,
Intel i7-10700KF.
32GB of 3200Mhz Ram (XMP profile 1)

The CPU runs most of the time at high frequency (4.7Ghz) despite CPU usage being around 0-1% on idle. On task manager it confirm low CPU usage and nothing is eating up resources.
In Windows, power plan is set to balanced, and min cpu setting at 5% whilst max at 100%.
BIOS is at default and I also tried to turn off XMP to see if there would be any changes, but nope.

I wish the CPU would just sit at 800Mhz when idle as it is supposed to be (I guess?).
I know this won't consume more electricity and won't wear out my CPU, but it's a matter of principle. I just want to understand why and if this behaviour is to be expected with this CPU.
Any clue?
Thanks

Massimo
 

TheFlyingCelt

Honorable
Jul 28, 2015
45
1
10,545
2
A message to those who will come across this thread due to MSI Dragon Center causing high CPU clocks on idle: after many days and lot of effort collaborating with MSI, they have finally made their motherboard managing software MSI Center compatible with many more mobos. I can't say that all the issues are completely fixed, but it's much better than before. Visit MSI website and give it a try if you're experiencing problems with Dragon Center.
And yes, it comes with Mystic Light to control your RGB, as many people around the globe have been asking for.
Again, it's not perfect, but I can see quite an improvement.
I hope it helps.
 
Last edited:

TheFlyingCelt

Honorable
Jul 28, 2015
45
1
10,545
2
I've just tried stressing the CPU with Prime95 and freq stays the same as when in idle overall. Whether the CPU usage is 0% or 100%, freq won't really change apart from small ups and downs.
p.s. during cpu stress test with Prime95 I have never even seen my cpu ramping up to max turbo 5.1Ghz. Why?
What a mess
 

TommyTwoTone66

Upstanding
Apr 24, 2021
373
85
290
12
This is normal behaviour. One of the cores remains clocked at full speed the whole time, the other 5 cores are downclocked to reduce power consumption. Whatever software you are using to measure the clock frequency is only showing you the frequency of the one core that remains locked at full speed.
 

TommyTwoTone66

Upstanding
Apr 24, 2021
373
85
290
12
Seems like MSI's implentation of turbo boost doesn't work so well so they default you to 100% all cores. Have you updated your BIOS to the latest version already? They may fix this in a later BIOS release.
 

TheFlyingCelt

Honorable
Jul 28, 2015
45
1
10,545
2
Seems like MSI's implentation of turbo boost doesn't work so well so they default you to 100% all cores. Have you updated your BIOS to the latest version already? They may fix this in a later BIOS release.
Yes, I have the latest 2.80 BIOS version installed, but the same thing happened with the previous BIOS that came with the mobo.
Also, any idea why it won't ramp up to 5.1Ghz turbo max when stressing the CPU heavily with Prime95?
 

TheFlyingCelt

Honorable
Jul 28, 2015
45
1
10,545
2
You are running at 800 because in the first link you set the cpu ratio to 8.
Probably that should be auto.
In the last link, I think you want to enable intel speed shift technology.
It was on Auto before when I started the thread. I set it to 800Mhz cause you told me so. The thing though is that it won't dynamically adapt to CPU load by setting a value, despite it should.
 

uWebb429

Prominent
May 22, 2020
115
42
690
14
Intel Speed Shift Technology is the best way to control any 6th Gen and newer CPU. This should be enabled in the BIOS.

Run HWiNFO and look for SST in green. That confirms if Speed Shift is enabled or not.



If Speed Shift is enabled, the Speed Shift EPP variable is what controls whether your CPU slows down or not when lightly loaded. Windows 10 was designed to control this setting but this might not work correctly if Speed Shift was not originally enabled when Windows was first installed.

You can use ThrottleStop to see what EPP value your CPU is set to.

https://www.techpowerup.com/download/techpowerup-throttlestop/

An EPP setting of 0 tells the CPU to run at full speed regardless of load. An EPP setting of 84 allows the CPU to slow down when lightly loaded. The ThrottleStop FIVR window will show you what EPP value the CPU is using. If Windows cannot control this setting then you can use ThrottleStop to adjust the EPP value.



To troubleshoot your problem, first look at the Task Manager Details tab and see how much stuff you have constantly running in the background. Most people do not understand that if a CPU has something to do, it is best to do that task at full speed and quickly get it finished.



Forcing a modern CPU to 800 MHz does not accomplish as much as you think it does. It should usually be avoided. You can have low power consumption with a fast CPU. Just make sure the C states are enabled. That is important. CPU speed is not.

 
Reactions: TommyTwoTone66

ASK THE COMMUNITY

TRENDING THREADS