Intel i7 9700k on constant Turbo Boost

Ololezhka

Reputable
Sep 30, 2015
20
0
4,510
0
Hello everyone!

I've recently upgraded from 5820k to 9700k and was suprised to find out that the CPU is running at between 4600Mhz boost clock in BIOS and windows. As you can probably tell, there isn't much load on the CPU in bios, but somehow, it still thinks it needs the boost.

Motherboard is Gygabyte Z390m. Bios version F3 (newest). Everything is on auto (if I desable turbo boost) the clock goes down to 3.6. Please advise
 
The 4.6ghz is the 9700k's all core boost. This is normal and means you have a decent cooler which allows it to hit that speed. It's perfectly normal.
Just monitor temps with something like HWMon. You're good to go.

 

Ololezhka

Reputable
Sep 30, 2015
20
0
4,510
0


Well, turbo boost is designed to boost your clock speed to max when under load, if it doesn't occur, then something is wrong, im trying to find what that something is
 

7664stefan

Honorable
Jul 18, 2013
355
0
10,960
55
Exactly, SpeedStep should cause a drop of the clock toghether with low utilization. Thus in your case the issue is most likely within the Bios settings for the CPU. Please check.
For Windows you might want to have a look at the power management options in the control center.
 


That's not exactly how it works. There is nothing wrong. Your CPU is operating as it should.

If you have high performance setting in windows profile it will stay at high clocks. Try a balanced power setting and it will downclock.



 

Ololezhka

Reputable
Sep 30, 2015
20
0
4,510
0


As I said before, power settings are irrelevant here. In bios, cpu is running at 4600Mhz in a restored default profile. Disabling turbo boost completely of course brings the change and sets the clock at 3600Mhz. I will be returning the board to Overclockers for this exact reason + 1SATA and 1 Usb 3.0 ports don't work. Hopefully won't encounter the same problem with a new board.
 

ASK THE COMMUNITY

TRENDING THREADS