Question Intel Iris Xe with Windows 10 doesn't allow 1440p over HDMI

Jul 6, 2021
8
0
10
0
Hello,
Last month I bought a ThinkPad X1 Yoga gen 6 with i7 1165G7 and so far I'm happy with that laptop, solid battery life, amazing performance for the igpu so on... Nice laptop but even with discount a bit expensive.

Anyway I have a problem with HDMI port on Windows 10 when I connect a 1440p monitor it's locked at 1080p max and I cannot select higher resolution.
I have a latest Intel Xe drivers (version: 27.20.100.9749) and Windows is updated to 21H1.
Image of intel graphics command center second monitor max 1080p => custom resolution set to 1440p doesn't work either
Image of intel graphics comm... info about second monitor #1
Image of intel graphics comm... info about second monitor #2 => here you can see that 1440p is in supported modes.


When I use the same HDMI cable for connection to 4K TV there is no problem with selecting 2160p resolution with 60Hz so there is no problem with cable.

But what is really strange is that in linux (tried Ubuntu, Kali) there is no problem of selecting 1440p and everything works flawlessly there.
Screenshot from linux display configuration that 1440p is working correctly
Before I tried linux I thought that it's unable to output 1440p res. but obviously there is a problem with Windows not with laptop or igpu.

Thanks you for advice and tips how to enable 1440p on Windows.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS