Question Intel(R) dynamic platform and thermal framework drivers -- code 31 ?

Mar 12, 2021
1
0
10
0
So about a year ago my computer started acting up. I tried to fix the problem and thought I had (usual things like doing a system diagnostic and the sfc scannow/ health thing). However I didn't fix the problem, and recently it seems to have gotten worse: I had BSOD with error "VIDEO_ random stuff_FATAL_ERROR", and my device has started to just freeze (no mouse movements, what ever sound was playing the instant it froze keeps playing like a buzzing sound), this happens when playing games so during high cpu,gpu and ram usage.

Recently I found the actual problem, the IDPTF drivers arent working, code 31. I did all the solutions I could find on the internet: re-did the sfc scannow and health thing, updated drivers (searched web option, also manually downloaded drivers from the device manufacturer-this came up with cant update because the drivers don't work). I then updated my bios to a more recent version. This didn't work either. So I tried uninstalling the driver/device (both with and without deleting the software associated) and neither of these fixed it. I then manually updated the drivers- uninstalled the driver and put all the correct files into the correct places to reinstall it. Stil didn't work.

Then I found the events for this driver (I hadn't looked until now) and I could see all the attempts at updates and uninstalls and such. But what was odd is the first event: in march 2020 (4 years after purchasing my laptop) the device uninstalled and reinstalled itself. I bring this up because it wasn't me who did this (I don't mess around with tech if I can help it) and the reinstall has description "device configured: null" and information:

Device ACPI\INT3400\2&daba3ff&2 was configured.

Driver Name: null
Class Guid: {00000000-0000-0000-0000-000000000000}
Driver Date:
Driver Version:
Driver Provider:
Driver Section:
Driver Rank: 0x0
Matching Device Id:
Outranked Drivers:
Device Updated: false
Parent Device: ACPI_HAL\PNP0C08\0

Now looking at that, it seems the device uninstalled itself and then set itself as empty, basically. Any help in making this work would be much appreciated.
My device is an ASUS ROG GL552VW laptop, and I have made no modifications.
Thanks,
Jordan.
 

ASK THE COMMUNITY