Question Intel Virtualization Technology Enabled (Won't let me boot into windows)

Nov 10, 2020
3
0
10
0
Hey guys so I've recently tried to learn docker and found that I need Hyper-V, in order to fully get that working I need to also enable intel virtualization technology. The issue I'm encoutering is when I enable VT in the bios my PC just hangs at the motherboard splash screen with a spinner that seemingly goes on forever. I've tried waiting it out for roughly ~20minutes once or twice but have not been able to figure it out. Obviously I've looked everywhere on the internet, updated windows and bios drivers and have probably been at it for about 2 days now. I've decided that throw in the towl and just see if anyone else has been able to help me solve the issue.
PC Specs: CPU: i7 8700k, RAM: 32GB, Motherboard: Z370 Killer SLI, GPU: Geforce GTX 1080
Edition: Windows 10 Pro, Version: 2004, OS build: 19041.610
Any advice or workarounds would be great!
 

Colif

Win 10 Master
Moderator
Did you ever sort this out? I just ran into the issue while trying to run Docker in Windows 10 x64.
It's definitely being caused by Hyper-V, but I haven't discovered exactly why or how to fix it yet. What I have found though in the meantime to still be able to boot into Windows (not just Safe Mode, and obviously without Hyper-V being usable once booted) is to toggle off Hyper-V via your BCD file.
You have to be able to get to a command-line though. What I've been doing is wait for startup repair to fail, then boot into Safe Mode. From there I open up an elevated (Admin) Command-line and type this:

BCDedit /set hypervisorlaunchtype Off

Then reboot.
If you have more than 1 item in your BCD you might need to specify which item to turn hypervisor off on. You can view all BCD items just by typing:

BCDedit

And to specify the item to alter, just add in its ID:

BCDedit /set {<long string of numbers here>} hypervisorlaunchtype Off

NOTE: When installing Hyper-V, it apparently automatically sets that flag to "Auto" (on) in your BCD, which causes the BSOD/Boot Repair Loop. Once you get the problem sorted out, you'll need to set that flag back to "Auto" to use Hyper-V again. I always make 2 boot choices in my BCD; one with Hyper-V enabled, one with it disabled. Then I select the one I want as needed.
https://superuser.com/questions/1321821/cant-boot-computer-after-enabling-client-hyper-v/1380090
 
Nov 10, 2020
3
0
10
0
Yea I've had a look at this before, I don't have Hyper-V enabled yet as I actually can't even get into windows without the PC going into an infinite loop on the splashscreen, it does not freeze or restart it just sits there loading forever it seems.

I've tried defaulting my bios which funnily enough enables virtualization by default which I have to turn off in order to get into windows, but keeping it enabled even with default bios settings still has the same issue.
 

Colif

Win 10 Master
Moderator
Nov 10, 2020
3
0
10
0
win 10 uses the hyper visor for memory management so I think having it on in bios might conflict with windows. I am no expert and only going from what i read looking at your question.

more docker instructions - https://d3v.one/windows-10-changing-hyper-v-support-at-boot-time/
https://forums.docker.com/t/cannot-enable-hyper-v-service/94086/8
I would think there is something on the docker forums about this.
Thats all good its hard to understand really, pretty much Im completely unable to turn on Virtualization via the bios without my PC looping forever just before windows boots this means I am unable to go into windows and enable the hypervisor. I need both Virtualization and Hyper-V enabled to use docker - with Hyper-V support disabled with:

bcdedit /set hypervisorlaunchtype off

I am able to enable virtualization but cannot enable Hyper-V
 

ASK THE COMMUNITY

TRENDING THREADS