Question Intermittent WiFi card issue

May 12, 2021
1
0
10
0
I'm running a Ryzen 5 3600 on an MSI B40M Mortar motherboard, which does not have onboard WiFi/Bluetooth. Therefore I'm using a Gigabyte GC-WB1733D-I PCIe WiFi card to provide that functionality.

I have a graphics card in the PCI_E1 x16 slot, two empty x1 PCI_E2/3 slots (effectively blocked by the graphics card), with the WiFi card installed in the x16 PCI_E4 slot (with no M.2 SSD in the M2_2 slot), although the card uses just a x1 connection.

I'm having an intermittent issue with the WiFi card. When first installed, the card is detected and works perfectly. However, after a couple of normal power cycles ('Shut Down' with 'fast startup' enabled, although I don't think this is the issue), for some reason the entire card (both WiFi and Bluetooth functionality) is not detected by the PC. Neither device shows up in Device Manager, or in BIOS.

Once the card isn't detected, it will never reappear, no matter how many times the PC is restarted ('Shut Down' or 'Restart'). The only way that I have found to fix the problem is to shut the system down completely, use the hard switch on the back of the PSU to turn the system 'off', press the normal 'Power' button on the front I/O, use the hard switch on the PSU to turn the system 'on', then press the 'Power' button on the front I/O to actually turn the PC on properly.

In doing this, it seems to reset the power state of the motherboard (or maybe the WiFi card), which allows it to reinitialise and detect the card. This fix will allow for a couple (usually 2 or 3) startups before the card disappears on startup once again. It’s a hassle, but it does work.

This isn't a new problem. I've updated the Motherboard BIOS a few times since this problem first occurred (currently on 7B89v1E), and I have ensured to update both the WiFi and Bluetooth Drivers whenever possible (currently Intel Wireless 21.120.0.9 and Intel Bluetooth 21.120.0.4). At this point, all parts of the system have used multiple Drivers (or BIOS versions), with no change in behaviour.

Finally, as part of the installation, the card requires connection via cable to one of the onboard USB2.0 headers. I've checked this by using two different 2.0 headers, with no change in behaviour.

So my question is this: What is causing this weird behaviour? Is it a fault with the WiFi card? Or maybe a problem with the motherboard? As far as I’m aware, there should be no compatibility problems using a PCIe x1 device in a x16 slot.

If it never worked, that I could understand and troubleshoot, but the fact that it sometimes works perfectly is stumping me. I could do with some help. Thanks!
 

ASK THE COMMUNITY

TRENDING THREADS