Internal and External HDD asking to be initialized/ formatted and both wont work

Oct 14, 2018
2
0
10
0
Hi, I basically use a SSD with windows installed and have an internal 3TB HDD for most of my other files which all of a sudden asked to be initialized in disk management and wouldn't let me access it. Testdisk and other programs won't recognize that the hard drive is even there so when I went to initialize it, disk management gives me the error "Incorrect Function". I've tried using a different port and using different wires for the HDD but it still doesn't work.

As this was happening I was using my external HDD while I was looking for a solution and the HDD all of a sudden stopped working and said I need to format it. When I try to format it I get another error saying it is unable to format the drive or I wont even get to that point and windows explorer stops responding if I right click on the external HDD. I've tried plugging it into a different computer and I get the same thing.

Does anyone know what gives? I'm scared to plug any other HDD into my computer and I don't really know what to do other than buy a new system all together.
 
Oct 14, 2018
2
0
10
0
Just an update - I've tried to mount the external HDD on linux and it was giving an input/ output error which I'm guessing means it is a damaged. However I'm still trying to find out what the problem is with my internal HDD.

I'm on Windows 10, I cant remember what my HDD was running on but I am pretty sure it was NTFS as all my other drives were running on that.

Not too sure about my motherboard either I have a Dell XPS 8500 so its not showing in System Information but according to one sold on amazon by Dell its specs are s115X, part # NW73C.

For the disk that is not working the partition style is "Not Applicable" but for the SSD it is MBR.
 

ASK THE COMMUNITY

TRENDING THREADS