Internal SATA to SATA transfer speeds at 20Mb/sec... Please Help!

Andy Van Conia

Distinguished
Dec 31, 2008
7
0
18,510
0
Hey Guys - First time poster here at toms.

I have a serious Issue with my transfer speed between sata drives and was hoping you could all give me some good places to look for my issue... I was gettign between 16 and 20/MB Sec according to the transfer dialog in Vista this morning while sending about 40 gigs at once with an average file size of around 400-600 megs...

COMPUTER:: (no overclocking on cpus or gpus enabled)

AMD Phenom 9950 (2.6 quad)
8GB G-Skill DDR2 800
Vista 64
Crossfire'd Saphire radeon 4850s (nice ones)
2 WDCaviar 500 GB 16mb cache 7200rpm (siSoft sandra shows them reading good and fast)
BIOSTAR TFORCE TA790GX - MOBO
Cooler master 650w power

Any suggestions or help would be extremely appreciated.

Other issues with the system you may want to know about since I built it a couple months ago are that the graphics adapters don't seem to be performing as well as they should playing Farcry 2 and other games at 1920x.... Weird color filling issues, frame-rate issues, etc.
 

grieve

Distinguished
Apr 19, 2004
2,709
0
20,790
4
How are you transferring the data? Just copying from C: > H:? Or are we talking about Ghost here?
20/MB Sec = 1200MB a min is not too bad....

I did a ghost of my drive this weekend with E-sata (same difference) and was getting about 2500MB a min; keep in mind that’s no OS running...Ghost.

-Try different SATA ports?
 

Andy Van Conia

Distinguished
Dec 31, 2008
7
0
18,510
0
This was just file data, OS running, moving video files to 2nd HDD to make room in program files dir... all internal drives..

So you're saying that's not bad then..? How not bad - should I be concerned at all? I just thought that 40gigs in moderate file sizes with 7200 rps drives would have been faster and Vista showing 16-20/MB sec was very concerning...
I know that windows confuses the heck out of itself when dealing with large file transfers as far as what the drives are actually doing, and what it shows in the transfer dialog...
 

Andy Van Conia

Distinguished
Dec 31, 2008
7
0
18,510
0
If you are correct and my drives are spinning at decent speeds.. I guess I should just go for the Raptors.. i mean.. I have terabytes of media and moving a few hundred gigs is not at all uncommon..

Further advice?
 

weilin

Distinguished
Dec 18, 2005
1,008
0
19,460
74
while it may be normal, 20MB/s seems a tad sluggish... Have you installed the latest drivers? more specifically, the latest chipset drivers? on AMD's website, its a pain to navigate but find the chipset section, get the unified driver, and then get the southbridge driver. Maybe that will help.

Byproduct if this would be updated video card drivers too which may fix the weird things you're experiencing in games.
 

Ancient_1

Distinguished
Oct 18, 2006
312
0
18,810
9
That seems pretty slow to me. have your drives been defrag'd recently? Are they fairly full? On my system I was getting around 60 between my 400 WD and 1.5 Seagate and around 90 going between my Seagate 1.5s.

Drives that are close to full or heavily fragmented can really slow transfers down.
 

Andy Van Conia

Distinguished
Dec 31, 2008
7
0
18,510
0
Video card drivers I know are up to date, mobo I did update when installed not long ago, processor not yet, HDD not that I can recall.. Thanks.

Any known compatibility issues with crossfiring 4850 gddr3 512s with phenom on an 8gig 64bit system?
 

Andy Van Conia

Distinguished
Dec 31, 2008
7
0
18,510
0
The drive I was transferring from was down to about 20 gigs remaining. The other practically empty. Both drives are less than 2 months old. Fragmentation due to file size I tend to have is almost definitely less than 1%
 

grieve

Distinguished
Apr 19, 2004
2,709
0
20,790
4
after doing some math... 20mb a sec is pretty slow, thats about how fast my machine transfers USB. (USB for me = 48 gigs in about 45mins, I did this just yesterday transferrring music)
 

AdioKIP

Distinguished
Jul 10, 2008
789
0
19,160
69
I just did a large transfer from Esata to an internal SATA drive and got about the same speed. Moving 777gigs worth of data the speed averaged 25 -29 mbps based on what Vista was saying. In all it took about 8 - 9 hours. I'm in the same boat as you in thinking that the speeds from one SATA drive to another should be higher....Anymore suggestions?
 

mantismn

Distinguished
Jan 21, 2009
12
0
18,510
0
I've noticed a problem similar to this as well. I have three WD 160GB drive in RAID5, and I just got a 500GB Seagate for storage. If I transfer something over the network (gigabit) from one of my roomates comps, I average about 40 to 60MBs according to vista, but transfering from my array to the Seagate, it starts at 70MBs and quickly drops to around 12MBs. That just doesn't seem right.

Just in case, here are the specs:

C2E QX6850 @ 3.5GHz
4GB ram
Vista x64
EVGA 680i Sli board
 

Ztoney

Distinguished
Jan 8, 2008
3
0
18,510
0
I just did a search because I thought my sytyem was moving slow. Just built a basic pc to serve as a media center for my TV and to use to store all my files. First major transfer I did was approx 300gb and took 2.3 hours. That seemed really high to me, but I dont think I have ever moved that amount of data at once, so I dont have a baseline. This is my first Vista box, so its hard for me to judge slow from fast. Being that this pc was created to host all my media, it does worry me a little. The drive I was moving data into was encrypted with TureCrypt, so I imagine that slows it significantly.

Currently I am moving 360gb of non encrypted files from one drive to a seperate one. It gave me an estimate of 1.6 hours at 62.4mb per sec. After reading these posts I found were to get the transfer rate. Wish I had noticed that earlier. Being that my system is very much basic on the hardware end, I would think that anything much under that would be a problem for those that asked. I still feel like this is slow, but as I see, it could be worse.

PC Basics For COmparison
ASUS MB Socket 775 Intel 4 Onboard Sata
Pentium 4 3.0 Socket 775 Single Core Processor (Told you it was basic)
2gb 800fsb Dual Channel Ram
Onboard Audio and Video
2 500gb Seagate Sata 3.0 Harddrives (1 is 16mb the other 32mb)
2 1tb WD Green Sata 3.0 Drive (32mb)

Hope some of that helps as your posts did help me.
 

rugersix

Distinguished
Mar 4, 2009
3
0
18,510
0
i too have noticed slow HDD speeds , i have 2 ea WD 250 sata 2 HDD. they say speeds of up to 300MB/s but according to HD Tune i am only getting a max of 63MB/s and a burst speed of 128MB/s, the mobo is a MSI K9A Platinum with an AMD SB600 sata controller capable of 300MB/s , so i am at a loss as to why such slow speeds? all drivers are installed for the mobo , checked with WD no jumpers mean full speed and there are none on HDD's they are close to full but the speeds were the same even when empty and i defrag at least once every 2 weeks or upon uninstall or reinstall of anything. so i am at a loss on this issue also checked the bios settings and all seem to be set to auto so ??? any help would be nice thx
 

ShadowFlash

Distinguished
Feb 28, 2009
166
0
18,690
1
@Andy...A common problem for me in server '03 x64 (especially over network )...try a little program called "Teracopy" when you transfer the big stuff. It's improved my transfer speeds, but don't expect any miracles....From my understanding, the problem lies with file copies that exceed system resources. There are registry hacks that do what teracopy does, but they are always in effect and suck for smaller copies. With teracopy you only use it when you need it ( drag and drop ).

@rugerSix....nothing wrong with those speeds...the 300MB/s they are refering to is the max transfer rate of the SATA II interface, not the drive itself. even the fastest drives cannot sustain this, but SSD's are getting close.
 

rugersix

Distinguished
Mar 4, 2009
3
0
18,510
0
so im guessing that they mean the total transfer speed the sata controller will handle is 300MB/s, ie 3 or 4 HDD's @say 60 MB/s would be a total of 240MB/s with 4 drive's ? kind of like a USB host controller, it only allocates a said amount of bandwidth for each port but the total is a lot higher? any way thank's for your help and i am watching prices for those SSD's will be able to afford them soon. just waiting for the less then a buck a GIG rule for 250GB and above drives, getting close. i remember when just 2 years ago a 32GB SSD was almost $2,000 ! lol now i think you can get a 32 GB SSD for around $150 or less.
 

Ignatowski

Distinguished
Feb 23, 2009
133
0
18,690
1


close. the sata 2 spec says 3gb/s. that is devided amongst the devices on that sata controller based on need. a single drive can theoretically push 3gb/s even if there are 3 other devices hooked up as long as they are idle. there is no cap per drive just the total bandwidth to the bus.

that being said the fastest single sata cable transfer ive seen was 207MB/s ( yes Bytes not bits) from http://www.acard.com.tw/english/fb01-product.jsp?idno_no=271&prod_no=ANS-9010B&type1_title=%20Solid%20State%20Drive&type1_idno=13,

rugersix: hold off till slc based drives come down. the mlc based drives suck when dealing with more than 1 io operation at a time but are pretty cheap nowadays.






 

rugersix

Distinguished
Mar 4, 2009
3
0
18,510
0
well thank you 4 your feedback. i am still kind of bumed , the HDD box says 300 MB/s and the mobo is 300MB/s and i get 130MB/s burst and about 63MB/s average......... o well. i think 4 now i will try a few 150 GB WD raptors in raid 0+1 and see what i get. with my system im waiting on my HDD's all the time. thanks again 4 your help
---------------------------------------------
Specs.

AMD X2 6000+ Dual Core @ 3.2Ghz
MSI K9A Platinum AM2 / AMD 580X NB and AMD SB600
4GB Corsair XMS2 DDR2 800/6400 D/C
Visiontek ATI HD 4870 512 MB GDDR5 @750/1005
On Board Realtek HD 7.1 sound
2Ea. WD SATA2 250GB 7200/16MB HDD's 1Ea. 750GB Maxtor USB 1Ea. 350GB Seagate ATA.
Win XP Pro SP3.
 

ddsman

Distinguished
Mar 23, 2011
1
0
18,510
0
I am transferring from a 2Gb Buffalo eSata drive (7200rpm) to (2)x1Gb WD Black Caviar (7200rpm) drives in a Raid 0 (striping) configuration and averaging about 65.0 Mb/s. It seems slow, but from what I'm reading this looks to be about right.

i7 920 (Overclocked to 3.80)
ASUS P6T Deluxe V2
6Gb OCZ PC 2000 RAM
2Gb ATI Eyefinity 5870
(3) x 24" Viewsonic LED
(2) x 1Gb WD Black Caviar HD (Raid 0 Striping)
Buffalo eSATA 2Gb
Sound Blaster Audigy & Logitech z680 5.1
Hauppauge 1199 WinTV HVR-1600
Win 7 (64bit)

 

spinnerman

Distinguished
Oct 10, 2011
1
0
18,510
0
ddsman

I'd be super pleased with that speed. That works out to 1 GB every 15 seconds or so. Or 4 GB per minute. I've got a similar type system with a newer i7 and 8gb memory. My 1 TB drive has an internal transfer rate of less than 1 GB per minute. I purchased a 3 TB external USB 3.0 drive and getting similar speeds of less than 1GB per minute.

Internal drive is SATA 3 as well. Dont understand why its so slow
 

cardog

Honorable
Mar 11, 2012
1
0
10,510
0
cardog

i have had up to 90 MB/s with 2 satas normal setup. Ubuntu Linux. Transfer speed with most hdd's are around 50-100. ssd's are are faster because no mechanical parts. when buying a hdd. the rpm speed is access time, how fast the drive will respond to a request. also helps with transfer rate. the drives cash is what is important. 7200 rpm with 16 mb cash will transfer about 100 mb/s, 5400 with 32 cash is about equal. 3gig sata or 6gig sata is bus speed not per drive. 20 mb/s is slow but 5400 2 mb cash, that is about right with windows, you will see faster speeds with Linux because they dont have a hundred things running in the back-round.

when buying usb externals no point getting faster drives like 7200 64 mb cash. usb only transfers about 20 mb/s any ways

sever drives= for day to day high rpm. cash wont help with streaming access time is what you are looking for

usb external drives nether matter. go cheap 5400 2-8 mb cash.

all other uses main os, large file transfer go with 7200 32-64 mb cash.

windows uses. stay up to date on drivers.

good luck
 

BriSei

Honorable
Feb 19, 2013
1
0
10,510
0




Its Cache not CASH
 

Royalty_Rules

Distinguished
Aug 7, 2011
2
0
18,510
0
Just a suggestion - I had a similar problem today, but on XP PRO, transfer speed between drives was slow, I am running a Sil-3114 PCI Sata Controller, and had a USB external hard drive plugged into a USB controller, a 300 mb file took more than 5 minutes to transfer from one INTERNAL SATA DRIVE TO ANOTHER SATA DRIVE Both connected to the same PCI Controller, BOTH ARE RAPTORS ... after troubleshooting, I found out that my external usb connected drive was to blame... unplugged USB cable and speeds sky rocketed... Prior to unplugging USB cable from Controller, I had updated the Controllers BIOS to 5.5.00 with no luck... just a suggestion unplug any usb devices you don't need, just for troubleshooting, and go from there ...

Solution, was obviously unplugging external HD, but I plugged it back, but this time to a Mb USB port, and the power usb to the Controller card, thus no problems with transfer speeds ...


***UPDATE***
Yesterday had the same problem again, I was at a loss... double checked that indeed my external HD was connected to the MoBo's ports and they were... however, my printer was connected to the USB PCI Controller, unplugged it and speeds increased once again... must be the USB card and not the external HD... I can live without the USB Card, don't need it really... it was an old card I threw in from my old computer...
 

ancient-techead

Honorable
Apr 13, 2013
1
0
10,510
0
 

Similar threads