Question Internal wireless card broke after using TP-Link Archer T2U

Feb 12, 2019
1
0
10
0
Hi!

Recently I bought a TP-Link Archer T2U USB dongle, because I wanted to connect my laptop (a Sony VAIO E-series with 64-bit Windows 7), equipped with a single-band Intel Centrino Wireless-N 2230, to a 5 GHz WiFi network. I installed it successfully and it worked rather well with that router. However, soon after I discovered two huge issues.

First and foremost, the internal N 2230 stopped working. I cannot detect any WiFi network when the dongle is plugged out or turned off. Even though the network card and its drivers are showing as properly installed and running, running the Windows diagnostics tool on this connection results in a message that the device is turned off and that I should turn it back on (I don't have a physical button for this in my laptop, also the LED indicates that wireless is on, so this is most definitely not the case).

I could just suck it up and always use the dongle from now on, but the second problem is that I cannot achieve a stable connection with my home router (Actina Cerberus P6800). It frequently breaks off and reconnects even while less than two metres away from the router. It is too flimsy to even browse the internet comfortably. I have absolutely no idea what the problem might be in this case, but it does not seem like there is something wrong with the router, any other device connects flawlessly.

So far I have tried turning everything off and on again in different configurations. I reinstalled the drivers for the Archer and the N 2230 and made sure they are up-to- date (version 15.17.0.1 for Intel and 5.1.34.0 for TP-Link). All to no avail. Earlier I also tried to perform system restore to the state before Archer installation, but it could not finish successfully even with the antivirus off. So I am at my wit's end. Did anyone else experience this kind of problems and was able to solve them?
 

ASK THE COMMUNITY