Internet Explorer 10 opens multiple pages automatically

Alys63

Honorable
Feb 27, 2013
2
0
10,510
0
One simple click on the Internet Explorer "e" makes DOZENS of my homepages open automatically. I have Windows 8, but NOT a touch screen. Any ideas on how to fix this issue??
 

kuruptangel

Honorable
Feb 11, 2013
30
0
10,540
1
They may be already open tabs that are left hanging. To close out the app, move your cursor to the top of the page so that the little hand shows up, click and drag to the bottom of the screen to close out the browser. This should refresh it.

Another thing is that you may have created multiple start up pages once the browser boots. Those are adjusted through internet options.

Finally, you may have let in a virus...
 

Alys63

Honorable
Feb 27, 2013
2
0
10,510
0
Thank you, but it can't be the first one because I don't leave tabs or pages open, and I mean there are 50 or more pages that open up in mere seconds. I usually use W8 in the "desktop" mode, not through the tiles, since my laptop is NOT a touch screen. I have checked Internet Options several times; I have not created multiple start up pages in those settings. Ran Malwarebytes -- it found nothing, nor did the scheduled Norton Scan. Sigh.
 

kuruptangel

Honorable
Feb 11, 2013
30
0
10,540
1
IE is very buggy in general. I would suggest switching to google chrome. If you're set on IE, you could try going back into internet options and restoring the default settings for the browser assuming you haven't already done that.
 

shanghaied

Distinguished
Aug 26, 2009
7
0
18,510
0
I wish I had a solution. It seems to happen on Amazon only in my case. It suddenly explodes with duplicate windows especially when I use the scroll button on the mouse. It just started doing this a few days ago on about March 15, 2013. I am using IE 10. It seems like a virus that affects only Amazon. If I use my laptop computer it doesn't do this.

I am not interested in generalized suggestions to switch to Chrome or other opinions to avoid IE. . I don't like Chrome at all. No way that it is as good as IE.
 

property agent

Honorable
Mar 21, 2013
1
0
10,510
0


simple and I just found out , move your mouse to the internet explorer, right click and select " internet explorer " , repeat it and you will get dozens of it.
 

shanghaied

Distinguished
Aug 26, 2009
7
0
18,510
0


I am about 95% convinced this is some kind of virus infection that has somehow slipped through the antivirus software. I have run two different antivirus software applications for hours, but neither of them finds anything. I have two other computers that work fine with the exact same version of software. Originally I was using IE9 when this started. Then I upgraded to IE10 hoping it would go away, but it didn't. Also I have a third computer that is running Windows 8 without this problem. The problem is only on one computer. This is why I think it has to be a virus. My problem is slightly different than yours, I think. But it is basically the same. I have only experienced it on the Amazon.com website - nowhere else. I am about to give up and format my disk and reinstall all the software. But I really don't want to do that. I have so many applications that will need to be reinstalled. It will take days to recover. I just hate the people who write malicious evil virus software. I guess they get some perverted pleasure out of causing other people so much harm.
 

shanghaied

Distinguished
Aug 26, 2009
7
0
18,510
0


I just removed the Microsoft Mouse and Keyboard software application and it seems to help a lot. But if I use my scroll wheel viciously, I can still create the problem. But even so, it does not create nearly as many new windows. I can still create the problem, just not as bad as before I removed that Microsoft mouse driver. I am using a Microsoft mouse, too. But I am using a different mouse model on my other computers. I really think this is a mouse software driver problem now. Who knows? Time will tell.
 

shanghaied

Distinguished
Aug 26, 2009
7
0
18,510
0
I gave up and installed Mozilla. It works without this multiple pages exploding. I think I will have to totally reinstall Windows 7 and start over to fix this problem.
 

Billy Balchin

Honorable
May 13, 2013
1
0
10,510
0
Go to internet explorer options and check homepage settings as mine had three google .co.uk homepages set,
I deleted these and its now working perfectly no more multiple pages loading hope this helps.
 

wmc1956

Honorable
Jul 5, 2013
1
0
10,510
0
Absolutely amazing. iexplore.com kept appearing in task manager multiple times and as soon as you ended the process more appeared. Also when I tried to open Internet Explorer it would open like 15-25 windows. I did what you said and changed the home page from google.com, which is not working on this computer (which is another whole story), and it fixed the problem! No more iexplore processes opening unawares! It opens only one window now, but that might have been fixed by running some other procedures suggested on daniweb.com.
 

davewatson123

Reputable
May 24, 2015
4
0
4,510
0
Had this problem.
The things I did.
1st download Rogue Killer. Run and get shut of pup files.
then download malware bytes, Run and get shut of pup file.
Then lastly download bitdefender, 30 day trial
Run complete scan this will delete malware byte and hunt out most virus's. Trojans etc.
when everything complete restart machine. Maybe a slow process depends on machine you have.
Everything works great now cpu usage below 10% no rogue internet pages opening with sound coming over speakers.
By the way had AVG running before but deleted it before I began. Now running bitdefender.
Windows 7 64 bit.
 

Jenney_1

Reputable
Aug 27, 2015
1
0
4,510
0
Hey, I realize this might be about 2 years too late for a couple of you, but I was having the exact same problem and found a pretty simple fix. It's a hot key problem. My laptop's mouse likes to move by itself and kept opening like 50 of the same webpage that I had never been to. Totally unprompted and seemingly by itself. As it turns out, the mouse (I am on a laptop, it is the mouse physically on the keyboard, but for others it could be a sticky key). The fix can be applied by running going to your "Run" button and typing Regedit.exe and navigate to the following location:
HKEY_LOCAL_MACHINE SOFTWARE
Microsoft
Windows
CurrentVersion
Explorer
AppKey
7

In the right-pane, double-click Association (could still be in the left depending on your version)
It should show the website your browser keeps going to and you want to change it to a "null" string. The current default is http
Close Regedit.exe

It actually wasn't that difficult. I copied and pasted that from where I found it and I was using Windows 8 but it still worked! NOT a virus! Yay! If you have any questions, let me know and good luck!
 

mgkeaton

Reputable
Oct 9, 2015
1
0
4,510
0
Issue was happening to me. Opened up IE and it would open at least 10 blank tabs.

Went to: C:\Users\Username\AppData\Local\Microsoft\Windows\Temporary Internet Files

Selected all and deleted.

Issue was resolved! Hope this helps.
 

Similar threads


ASK THE COMMUNITY