Question Internet speed is slow on new computer

Dec 25, 2019
2
0
10
0
Disclaimer, not very tech savvy.

I've been having trouble with my computer's internet ever since I got it last August and figured it was just a problem with our provider but I decided to take a look on my brother's PC and he's getting 100Mbps of download whilst I get less than 10Mbps, which is dumb considering he's using a WiFi adapter and I'm using an Ethernet cable so I'm starting to think it might be a hardware problem.

My current specs are:
Motherboard: MSI B360M Xtreme (CPUSocket)
CPU: Intel Core i5 @ 2.90GHz
OS: Windows 10 Home 64-bit
RAM: Single stick of DDR4 8.00GB
The internet provider we use is Bell Canada and I'm currently connected the home hub 300.

Second computer specs are:
Motherboard: Dell Optiplex 390
CPU: Intel Core i5 2400 @3.10GHz
OS: Windows 10 Pro 64-bit
RAM: 2 sticks of DDR3 8.00GB
The WiFi adapter is a TP-link 300Mbps

We have around 2 PCs connected at almost all times, a laptop on half the time and around 4 phones if that helps in any way.

Any help would be appreciated, thing's been haunting me for months
 
Dec 25, 2019
2
0
10
0
It's connected directly to the modem using a flat ethernet cable, same one I used to use on the second computer which I believe had around the same download and upload speed.
I should probably ask which on is which, I ended up making this one myself, and round cables look different from what I can understand.
Looks like this !
 

ASK THE COMMUNITY

TRENDING THREADS