Question IPv6 Broke my DC?

Benkberg97

Reputable
Jun 4, 2015
66
0
4,660
16
Hi all,

I have a situation that others have had in the past, but I have tried many solutions to no avail. Basically, I am running a Windows Server 2019 DC, but Windows 10 Pro clients are unable to join or log on to the domain if IPv6 is enabled on the client. Running NSLOOKUP with IPv6 on yields a non-existent domain result. With it disabled, it resolves and points to my DC. The most peculiar thing is that any macOS client can join with IPv6 enabled. I have tried checking the obvious (Making sure the primary DNS server for IPv6 on the DC is set to loopback and verifying that there is a valid forward lookup zone.) I also made sure that under advanced properties to check the option to register the connection address in DNS. Still nothing. Pinging the DC by hostname with IPv6 enabled causes a response from an IPv6 address, which appears to be the address of my modem. Adding the -4 switch yields a reply from my DC. My modem is from Comcast and I have verified that its DNS and DHCP roles are working properly.

Any ideas?

Thanks!
 

ASK THE COMMUNITY