Question is 400W PSU enough to run this?

May 19, 2019
13
0
10
0
hi,

CPU I7-3770 with stock cooler
GPU gtx 1060 6GB
32GB ddr3 1600 ram
got 4 case fans RGB
toshiba sata drive 240gb
1tb hdd

my case RGB fans seem to turn them selfs off and on when they feel like it but if you give them a little push they come back on, just wondering if they arent getting enough Watts
 
May 19, 2019
13
0
10
0
so do you think 400W is enough to run all my components? everything is working perfect apart from the fans turn off and on ramdonly, theyll work for weeks on end then stop for a few days, ive tried different fans hubs that connect the fans and still the same, they start working again after you give them a little push..

im new to pcs so dont really know much

also the GPU is evga gtx 1060
 
Components should only draw as much power as they need. I'm a bit sceptical that not enough power is delivered at, eg boot up. I'd guess it's possible the fans themselves may be wearing down, but would depend how long you've had them. There's also the possibility that some software controls the fans too.
 

Phillip Corcoran

Titan
Moderator
No-one has yet asked you to post the PSU make & model --- and it's essential for us to know that (you should have included that info in your specs list).

Why? --- because there are good and bad models and brands --- most of the bad ones don't even supply the wattage that they claim to.
 
May 19, 2019
13
0
10
0
hi yeah sorry the PSU brand is FSP group

the PC is only a month old bought it brand new and ive tried using speedfan to try control them and no luck, the fans are connect to a fan hub box called Rainbow 5p which is then connected to the PSU via sata

theyre on at the moment but just find it strange how after a few days/weeks theyll turn them selfs off and not come back on for days
 
May 19, 2019
13
0
10
0
And most of the good ones do not come in the 400watt range also?
Components should only draw as much power as they need. I'm a bit sceptical that not enough power is delivered at, eg boot up. I'd guess it's possible the fans themselves may be wearing down, but would depend how long you've had them. There's also the possibility that some software controls the fans too.

Also, when the pc is turned on and the fans are not spinning if i un plug the fan hub box and plug it back in they start working
 

ASK THE COMMUNITY