Question Is a msi rx 570 armor 8gb compatible with an m5a97 mobo?

Jun 18, 2019
10
0
10
0
Hi, its been years since I have built anything pc wise. Recently my card popped so I had to buy an new one.

I bought at a good price an rx570. I have since installed it an it powers up but I have no signal on hdmi or dvi-d.

I realise in some case you would need more specific info which I can ofc provide. I was hoping someone may have come across a similar problem or question. I am under the impression that its more than likely that my parts are too old for said hardware but thought the price of embarrasment of asking only cost pride where as the parts cost cold hard cash. Any help would be great nd any more info needed I will gladly give.
Thanks.
Joe.
 
From a "plug and play" perspective, it should... Just go to your motherboard's manufacturer site and check if there are new BIOS upgrades available as some PCIe 3 GPUs don't work right off the bat (EDIT) on older motherboards.

Additionally to the above, what GPU did you have before? I'm conscious the RX570 may use a bit more power than what you had before if you're going from midrange to midrange, so the PSU is something to consider as well here.

Cheers!
 
Jun 18, 2019
10
0
10
0
From a "plug and play" perspective, it should... Just go to your motherboard's manufacturer site and check if there are new BIOS upgrades available as some PCIe 3 GPUs don't work right off the bat (EDIT) on older motherboards.

Additionally to the above, what GPU did you have before? I'm conscious the RX570 may use a bit more power than what you had before if you're going from midrange to midrange, so the PSU is something to consider as well here.

Cheers!
I had a 6950 if i remember correctly using a 6 pin power connector. My psu is coolermaster 600w
 
What's the exact REVISION of your Motherboard ? There are two versions of that mobo, and the BIOS date is also pretty much different.

Version 1605, dated 2012/10/31 ------------> Of the older motherboard.

Version 2603, dated 2015/07/24 ------------> On the revised R2.0 SKU.
 
Jun 18, 2019
10
0
10
0
What's the exact REVISION of your Motherboard ? There are two versions of that mobo, and the BIOS date is also pretty much different.

Version 1605, dated 2012/10/31 ------------> Of the older motherboard.

Version 2603, dated 2015/07/24 ------------> On the revised R2.0 SKU.
M5a97 pro (haven't uograde bios yet as im cooking tea for my minions 😁)

And the psu is the coolermaster gx650 watt, sorry if that isnt the info you want, il gladly go back an find whats required.
 
Jun 18, 2019
10
0
10
0
Fixed it finally. I had to have my old card in and used as primary with the new card in the second slot. I was then able to see it i device manager and installed the driver. Shutdown, removed old card repositioned new card and yurned back on to install the rest of te gpu software. Thanks for all your help folks. Really appreciate it.
Joe.
 

ASK THE COMMUNITY