Question Is EVGA RTX 2070 XC ULTRA Super my issue?

Nov 16, 2019
3
0
10
0
NOOB ALERT

Just built my first PC:

9900k
ASRock z390 PH X
Corsair 32GB Kit (CMK32GX4M2B3200C16)
EVGA 2070 Super XC ULTRA
Samsung 970 Evo Plus 1TB (Boot) (Magician installed)
Samsung Evo 500GB SSD
Corsair RM850x
NZXT Kraken62

Monitor: LG 34gk950g-b

Everything runs perfect, temps, blah blah blah. Except for one thing


Could be 10 minutes or 30 minutes into gameplay and my GPU utilization immediately drops to 0% and game freezes in and out HARD. No blue screens. CTL ALT DEL will sometimes not allow me to the desktop, and if it actually does, and I close the tasks on all apps, i still get stuttering freezes.

-Multiple online remedies that have worked for other on forums, youtube, etc, such as DDU, BIOS update, ran RAM diagnostics that took forever, Windows updates, driver old and new, regedit, blah blah blah.
-Things I haven't done: Re installing Windows, removing magician software, gaming at a lower resolution. (I imagin that the hardware can handle 1440p right?)

NO OVERCLOCK aside from activating XMP profile on memory.
Temps have been completely stable per CPU Z, EVGA X1, MSI Afterburner. Cinebench R20 is the only benchmarking software I have and CPU temps never exceed 72. GPU temps never exceed 62 for that matter when Im able to play.

I humbly ask if anyone has any suggestions on what I can do. Ill answer any spec questions you may have.

Do I need to RMA the card? Or am wayyyyy off? Thank you in advance.
 

Lutfij

Titan
Moderator
Which version of Windows 10 are you on? Which BIOS did you update to? You should breadboard the system with the bare essentials first and then work your way up by gradually adding hardware(while it's powered down ofc) and see if the issue can be replicated.

Often times people over-tighten the AIO's mounts.
 
Nov 16, 2019
3
0
10
0
Wow thank you for your response.

I updated to Windows 1909.

Updated to Asrocks only update for this motherboard since release 1.10

please bare with me, by breadboard do you mean removing all apps, software, and files? I’m new I apologize.

since posting I did replace the PCIE cord and ensured connectivity was g2g. I removed the HDMI from monitor to pc (Had both HDMI + Display Port in at the same time) No improvement. I also reinstalled the GPU to ensure good connectivity.

Am currently running Heaven GPU basic benchmarking (now at 1hr) and stable regarding FPS/temps) Still going strong at the moment.
Worth getting a multimeter for PSU testing? My rm850x fans have not kicked on since running Heaven but I can only imagine it’s bc I’m not pulling enough wattage.

as far as the possibility of over tightening the AIO on the CPU, and by your other suggestion of breadboaring, do you mean I should reinstall everything hardware wise? I apologize for being naive. Thank you in advance.
 
Nov 16, 2019
3
0
10
0
Still at a lost. The past 2 days games have been fine after changing Windows Performance from "Performance" to ultimate. Although knowing that the function would not improve gameplay I said what the hell do I have to lose?

2 days, g2g. However just now the same old crash and freeze, GPU droppage and barely letting me back to desktop. When I close out the game it finally stabilizes and allows me to move cursor freely again. I am just at a lost.

Not sure if I should RMA the 2070 Super, or the PSU, or what?!

Please, if anyone has any suggestions please let me know. I'm officially out of ideas.
 

ASK THE COMMUNITY

TRENDING THREADS